280Z Hogging up Gas!


richn95136
02-19-2004, 03:12 PM
My 280Z has recently been getting horrible gas mileage. All of a sudden I am only getting about 8 miles per gallon! What is the first thing that I should check? Help!

ScarabZ
10-12-2004, 11:23 PM
Really need to know the year of your Z but the first thing I would replace which is cheapest is the Temperature sending unit for the FI which again depending which year you have is located on the side of the head by the oil filter. This water temperature sensor is notorious for send the wrong message to the ECU which tells it to richen or lean the fuel mixture. After that I would check the Air Flow meter and make sure nothing is stuck in it is working properly, And you can also have a bad cold start valve stuck open. And Of coarse BAD GROUNDS to the engine will cause this problem. I know it's a lot to look at but you check these Items first and maybe you'll get lucky..

Cam1970
10-19-2004, 02:20 PM
Also check the fuel filter (dirt cheap to replace, tends to clog up if the gas tank is sluggy or gas was not 'pristine'). Not sure if you have carbs, but also check the timing and perhaps adjust the carbs (again, if you have them); if they're
off', the fuel to air mixture could be causing you to waste gas.

And last (but certainly not least, specially if the car is otherwise running well), check the gas tank for even pinhole leaks, as well as any and all fuel lines. I'm speaking from experience here: though my '70 240Z was running rough, the gas mileage was appalling - small pinhole leaks around the 'holding straps' (I'm not an expert with the lingo yet) were dropping a spray of gas when I was driving, which in a way meant that I really didn't smell gas.

Add your comment to this topic!