Noise under feet


biletchi
01-06-2004, 03:48 PM
I have a 2000 GMC Jimmy which just recently had the brakes and rotors as well as the U joints replaced on the front and rear. It has about 100,000 km on it. When I drive it makes a weird clunking noise over and over in the front section right under the passenger and driver's feet. The noise is not overly loud but it is noticeable. I was wondering if anyone had any ideas as to what it could be? I also am experiencing problems when I turn quickly to my right and come to a stop like parking. It seems as though when i do this the ABS kicks in? would the two possibly be related?

missyjord
01-07-2004, 01:21 PM
Funny I've had the EXACT same thing! In my case they were not related. The noise was the front differential, check your oil level in it, it could need to be filled. I don't recall off hand what was causing the problems when turning and stopping, but it wasn't really a problem. I f I remember what it was I'll let you know.

biletchi
01-14-2004, 08:59 AM
Funny I've had the EXACT same thing! In my case they were not related. The noise was the front differential, check your oil level in it, it could need to be filled. I don't recall off hand what was causing the problems when turning and stopping, but it wasn't really a problem. I f I remember what it was I'll let you know.

Turns out that the problem was the wheel bearings. I had them both replaced at a cost of $257.00 each plus labour bringing the total to around $900.00. Those hub/bearing assemblies are real expensive.

petriw
01-25-2004, 03:02 PM
Have the same problem on mine. Don't think it is the wheel bearings though as it is an intermittent klunk.

Andipandi
02-23-2004, 08:21 PM
Hey.. I seem to have a similar noise coming from my 91 Jimmy.. I had it to my regular mechanic and he had one of his guys do the work on it over the weekend. All he needed to do was replace the Y pipe and change the oil. I left and got on the highway heading home and noticed that there was smoke coming out behind me as I drove. Pulled if off and popped open the hood to find oil everywhere.. and leaking on the ground. Wheeled it into Walmart Oil change place and they couldn't see where it was coming from. Took it to a mechanic to figure out that problem only to find out the PCV valve was packed and that was causing the problem.. NOW.. it is making his horrible grinding type noise as I accelerate after the truck has been warm for about 5 minutes.. I was kicking in between 40 and 60 km and hour and then eased off.. now it is doing it from 20 up to around 60 kmh.. once it is actually cruising at a speed the noise seems to subside a bit. I have drove it besides buildings to see if I can hear it with the windows open but no luck.. Could this be the transfer case or some other part of the tranny.. or U joints.. I had them replaced about a year and a half ago..
Any ideas would be great since I am a)female and b) new to the area.. and I don't want to take the chance driving it back to the mechanic an hour and a half away.


Thanks!!

Add your comment to this topic!