97 Silverado Z71 Transmission


UngerC
12-19-2003, 02:14 PM
Well the transmission to my beloved truck has, I guess, died. The truck is a 1997 Silverado Z71 with a 5.7 vortec AT 135K miles. (Mildly messaged engine, air intake, 33.5" tires 3.5" body lift. Hypertech pullys and stat)
Wouldn't go into reverse.
Wouldn't shift out of 1st until RPMs reached 4k
Whouldn't shift from 2nd to 3rd at all.
I checked trans fluid and it was full.

Took to AAMCO and they said that bands were broke and that the 'rebuild' specialist would look at it soon, to let me know if they could rebuild or I need to replace.

My questions are:
1: Do I have a 4L60E transmission, if not what kind do I have?
2: What should I expect to pay to have it rebuilt? replaced?
3: If I have to get it replaced I have been looking at several tranys online that are 'built' to handle more power/torque. Any recomendations?
I have looked at the PT4L60ERV from hxxp://www.phoenixtrans.com/html/gmtrans.html and the
'700 Raptor Junior " Level 2 ' from hxxp://www.transmissioncenter.net/highperf700r4.htm
any information on these or others not listed would be greatly appreciated.
OK two more things, are there any 5 speed auto's out there that would work and how about info for a manual conversion...
THanks...


replace xx with tt for urls

jkinney
12-20-2003, 08:03 PM
First of all, you might as well throw 1800 dollars out the door. They dont impress me in the least, and guaranteed they will tell you it needs rebuilt. If it WILL shift out of first at 4k, and your moving forward, the bands arent broke. It sounds more like a pressure problem. Have you checked your kickdown cable, and made sure it is adjusted right? or possibly broke? They can stretch too.

Jporter12
12-28-2003, 12:03 AM
You should have a 4L60E. Doubtful that it's a 4L80E, never seen one in a C or K 1500.

Last one I overhauled was around $1300.

If I had to make a reccomendation, I'd say www.pro-built.net just from the times I've called him for help and gotten what I need, even though I've not purchased anything from him!

I'm not aware of any 5 speed auto's that bolt in, and it should be easy to swap in a manual 5 speed, seeing that there are many 5 speed K-1500's out there.
Sounds like the Sun Gear Shell has broken. Aamco say the band (only has one!) because the band is what controls the sun gear shell. I've overhauled many of these for this issue. While it most likely doesn't REQUIRE a complete overhaul, I strongly reccomend it, since the transmission has to be more than halfway disassembled to fix it. It's also a good idea to use "The Beast" sun gear shell. A transmission parts supplier should be well aware of what it is.

trannyman52
01-05-2004, 11:11 PM
if the tranny fluid is not burned{black} and the oil is fairly red//
more than likely the sunshell is stripped from the output shaft

some shops will repair the problem//but if your going to get bent-over
look at GM's goodwrench tranny It comes with 3yr North American
warranty VERY VERY Good!!! {should be a 4L60E trans}
gbaum@email.com

JohnnyMac-Truckee
08-25-2005, 07:18 PM
First of all, you might as well throw 1800 dollars out the door. They dont impress me in the least, and guaranteed they will tell you it needs rebuilt. If it WILL shift out of first at 4k, and your moving forward, the bands arent broke. It sounds more like a pressure problem. Have you checked your kickdown cable, and made sure it is adjusted right? or possibly broke? They can stretch too.

Trans. in my 2000 Z-71 just failed. 57K original miles on the 4L60E. Will not stay in 3rd. I changed the filter and fluid - no change. I'm no mechanic, but I am mechanically skilled and have plenty of common sense. You seem to be knowledgeable in the area... is there something I can check or do? (besides bend over at the dealership)
Thank you,
Johnny Mac

MyTOY
08-26-2005, 11:06 AM
Rebuild w/TQ on my 97 was $1,600

MyTOY
08-26-2005, 11:06 AM
I meant TC not TQ and this was at Cottman

Add your comment to this topic!