Trac Control / ABS | Fuel Pump


97NA
12-07-2003, 11:53 PM
Howdy ya'll...
Got me a few problems here.

First The traction control and abs light seem to just want to go on... for no reason, could it be the constant snow and/or water? but if that than why when driving on some what dry cement it still turns on. brake fluid is full.

Now the seccond, When my gas gage gets to about 1/4 tank the gas gauge goes haywire! ie jumps from full to empty to full to empty and all over the place. and that annoying little bell goes off constaly(you know the one that tells you you are getting low on gas. Now some places say that it is the fuel pump others say it is the sending unit. now i do know that the sending unit is in the fuel pump so would it be easer to replace all of it or just the sending unit if that is what it is.. Also when i looked at it there is like a cross member welded to the chassie that looks like it holds the tank in. how would i go about this... Priciate all the help.
:2cents: :2cents: :2cents: :2cents: :2cents: :2cents:

Flatrater
12-08-2003, 06:03 PM
I would need some codes to help with the ABS problem! More than likely you have a bad speed sensor.

The fuel pump makes fuel pressure it would not cause a guage fluctuation. The sender is what reads the amount of fuel in the tank that is what I would change. It is real pricey to change the pump if not needed. To change the sender there is an panel in the trunk to get to the sender no tank removal needed.

97NA
12-09-2003, 03:10 PM
What would i need to do in order to get these codes

pimp98
01-07-2004, 11:26 AM
i have a 98 park ave ultra i had the same problem i would hit the brakes and the abs light and the traction off light would come on but if i turned the car off and turned it back on it would go off did your lights flicker at all inside what i did to fix it was replaced the battery fixed everything look and see if you have an a/c delco battery in it they are notorious for the side post breaking off inside the battery my gas guage was it went all the way around and got stuck but that looks like it would be easily fixed according to 98buickguy REPLACE BATTERY

PAPA Man
09-29-2004, 08:21 PM
Howdy ya'll...
Got me a few problems here.

First The traction control and abs light seem to just want to go on... for no reason, could it be the constant snow and/or water? but if that than why when driving on some what dry cement it still turns on. brake fluid is full.

Now the seccond, When my gas gage gets to about 1/4 tank the gas gauge goes haywire! ie jumps from full to empty to full to empty and all over the place. and that annoying little bell goes off constaly(you know the one that tells you you are getting low on gas. Now some places say that it is the fuel pump others say it is the sending unit. now i do know that the sending unit is in the fuel pump so would it be easer to replace all of it or just the sending unit if that is what it is.. Also when i looked at it there is like a cross member welded to the chassie that looks like it holds the tank in. how would i go about this... Priciate all the help.
:2cents: :2cents: :2cents: :2cents: :2cents: :2cents:

I have a 96 PA and the same issue. My ABS / Traction light started coming on and going off. Then it wouldn't go off. Also noticed that the ABS and Traction Control are disabled, don't slam on brakes thinking the ABS will assist - I found out the hard way! Anyway, not sure why except I read somewhere there is a "modulator valve" of some sort for the ABS that is notorious for going bad. Good luck and I'll keep searching.

Add your comment to this topic!