I need mechanical Help PLEASE


temochen
11-12-2003, 01:05 AM
I have an rx-7 non-turbo stick with major problems
My car is pumping too much fuel into the cylanders and my plug keep fouling out and carbonizing. I changed out the top igition coil, oxygen sensor, spark plug wires and plugs, went through and checked everything i can think of. It is a bitch to start and idles in the 500s. Back it is olny running on the bottom cylanders and the top is doing nothing. I know the ground to engine is a problem and i checked it throughly. Vaccume is checked and engine is not blown. I has power olny 1/4 the way through the peddle. Im in the kansas city area and if anyone knows someone i can take this car to please e-mail me.i have no idea what the problem is and i have went through everything i can think of. i need help please!!!!!!!!!!!

venomous354@earthlink.net

Steel
11-12-2003, 01:34 AM
No cylinders, mate. I dunno what you mean aobut the "top" and "bottom" cylinders, but it sounds like your throttle position sensor may be off. It could also be a whole host of other stupid problems. If it is indeed too much fuel, check out the injectors, the intake and whatnot.

DavidovSpeedWRC
11-12-2003, 02:49 AM
If by "top and bottom cylinders" you mean leading and trailing spark plugs....how did you determine that the REAR ROTOR is only running on the bottom(leading spark plug).

What kind of spark plugs are you using?

J-Rat
11-12-2003, 09:19 PM
I have an rx-7 non-turbo stick with major problems
My car is pumping too much fuel into the cylanders and my plug keep fouling out and carbonizing. I changed out the top igition coil, oxygen sensor, spark plug wires and plugs, went through and checked everything i can think of. It is a bitch to start and idles in the 500s. Back it is olny running on the bottom cylanders and the top is doing nothing. I know the ground to engine is a problem and i checked it throughly. Vaccume is checked and engine is not blown. I has power olny 1/4 the way through the peddle. Im in the kansas city area and if anyone knows someone i can take this car to please e-mail me.i have no idea what the problem is and i have went through everything i can think of. i need help please!!!!!!!!!!!

venomous354@earthlink.net


Okay, do you have a timing light? Because we need to verify your spark. Secondly, how many miles on the car? Have you put aftermarket injectors in? Possible you have a bad injector (most fail to the closed position, but you never know).

WHATEVER YOU DO, use NGK PLUGS~!!!

And third, your a rotary owner. You dont have the following:

Pistons
Cylinders
Timing Chains
Heads
etc...

Jarrett

rxv8wannabe
11-24-2003, 02:46 AM
Hold on now I just put those ngk plugs in my car now I can notice the car has a miss in it at around 3000 rpm. Also put some huge wires on I got from mazdatrix. Whats up?

DavidovSpeedWRC
11-24-2003, 02:55 PM
It's probably the classic 3800 RPM hesitation.

J-Rat
11-24-2003, 03:47 PM
Does your stumble happen at 3800?

Add your comment to this topic!