Page updated on 05-24-2018

90 eagle premier electrical


kambalaman
07-26-2003, 01:07 PM
This car was on it's way to the boneyard,when I took it off the owners hands for free.The engine,trans and air work good.The windows work here and there.I replaced master control from boneyard with same results.They are strong when they work.The ventilation fan works only on high speed.Thanks in advance and nice site! :bigthumb:

ifehr_2000
10-30-2003, 07:49 PM
Did you ever fix the blower fan? because mine does the same thing.

driveway
07-10-2004, 11:27 PM
the blower problem is for sure the resistor under the pass side dash and conected to the heater box with two screws and will be next to the blower motor. I promise you that is the problem

wilkin250r
09-21-2004, 05:12 PM
Is this a common problem? Mine does the same thing, it only works on "High". Actually, it USED TO only work on high, now it doesn't work at all.

What other common problems are there? All my selections for air controls work, but they are not illuminated, so it's impossible to know what the settings are at night. Common problem with an easy fix?

driveway
09-22-2004, 01:34 AM
yep its a common problem with general motors vehicles as well, mostly older stuff. but it is a cheap easy fix that anyone with a small socket set can do in less than 10 minutes. as far as the climate controls lighting up I would check fuses and bulbs first, I have seen lots of people spend way too much for a few hours of labor charges at a dealer just to find out it was a fuse or a bulb. if those are good then I would start checking connections and wiring. mine used to not work and it was a loose conector in the steering column, tightened it up and it has worked great ever since.

Add your comment to this topic!