Is it normal with a 156 1.9 JTD?


AlfaMan
07-09-2003, 10:14 PM
With my 156, on the highway, i can't pass the 190km/h, is it normal? I think that maybe the "Turbo" is not working 100% 'cause when he gets to 2500rpm i feel him to loose strenght! :frown:

Jimster
07-11-2003, 06:26 PM
That doesn't sound right- does the car just simply die at 2500- or does it sit there for a while and then finally move along- if it's the former then I'd give it some attention- if it's the latter- then it's Turbo lag- which shouldn't be happening on the 1.9JTD- in which case it's best to take it to a garage/dealer to sort it out

AlfaMan
07-12-2003, 08:17 PM
He doesn't simply die after 2500rpm, he keep going but more slowly, or with less power! Probably it's Turbo Lag as you said...:frown:

Jimster
07-13-2003, 03:45 AM
Originally posted by AlfaMan
He doesn't simply die after 2500rpm, he keep going but more slowly, or with less power! Probably it's Turbo Lag as you said...:frown:

Definitley turbo lag then- you should have the turbo checked out- it shouldn't be lagging by all means

Volken
07-13-2003, 05:33 AM
I had last year previous experience with friendís Alfa 2.4JTD.

We went to my friend who is dealer for English chip/tuning brands and also some Italian and German cars. They have made my previous chip installs, so friend wanted to boost his 2.4JTD.

This manifestation you are referring with your Alfa can be partial in many ways.

Friendís 2.5JTD had similar behavior but at much less power, his engine was nearly that below 2500 and was really breathing like atmosphere engine.

After remedy of the engine in service, one of air controls (protecting turbo),much like fuse jumped out therefore limiting engine in such condition.

Fast, and inexpensive was the cure.

However, from experience, this deficiencies like yours are mostly when drivers are pushing engines harsh above 3000rpm where it is no longer efficient and potentially wearing if driver makes habit of it

Stefanel1
07-15-2003, 11:52 AM
The 156 JTD 1.9 105hp is given for 188kmh, you could get the 200 tachimeter...

AlfaMan
07-17-2003, 08:19 AM
Thank's for your help guys!! I'll take my baby to alfa dealer to check out the turbo, but unfortunetly now ir's not the beste time $$ :frown:

edpole
12-11-2003, 01:07 PM
I had a 2.4 JTD with the same problem. It feels like a turbo problem when you drive it but its actually the Mass Air Flow Sensor on top of the air box. In UK money about £150. It's a very inportant sensor in the control loop. It controls fueling and boost etc....

AlfaMan
12-13-2003, 06:19 AM
Yes edpole, the problem was just that, i went to my Alfa dealer and they resolve the problem. Was about 500Ä. And now it's great!

Add your comment to this topic!