Quad Driver failures - 1995 Lesabre


DStyduhar
05-21-2019, 10:06 AM
Hello,

Weird sequence of events here that has resulted in my Buick throwing P0640,P0650 and P0670 Quad Driver codes. Gotta love the OBD 1.5 cars.

Last week the driver's side front power window motor stopped working. Simple fix, verified everything worked, put panel back on and went inside for the night. Came out the next morning to go to work and the engine would crank, crank, crank but wouldn't catch at all. I disconnected the battery for 5 minutes or so, reconnected and it would crank/start just fine but immediately threw a check engine light and RPMs are up at 2K or so at idle. I have tried disconnecting the battery and starting the car over and over and sometimes the RPMs will run away on me and I have to shut it down. The engine runs smooth though, not missing or anything just really high rpms. I was driving this car every day and its never done this. I WANT to think it's too much of a coincidence that I got in the door, and now it's acting weird.

Here is what I have done so far:

1. Removed door panel again and disconnected everything - no change

2. Checked all functionality, mirrors, lights, horn, etc. trying to find something that is not working all of a sudden - everything is fine

3. Test light on all fuses - nothing is blown

4. Listened in engine bay for vac leaks and sprayed around intake manifold, tb, etc. - cant hear vac leak and no change in idle response

5. Remove intake tube and looked in TB - very clean as I replaced lower intake manifold last year.

6. Ohmed out injectors - all 13.5-14.5 ohms

7. Replaced IAC with new one I had sitting around - no change

8. Replaced ICM with spare I had sitting around - no change

9. Hooked up my scanner and watched sensors:

TPS - showing 0% and .52V @ idle which I verified via backprobe
IAC - counts = 110 (didn't seem unreasonable)
MAF - 11(cant remember units)
ECT - temp was correct
Timing - 17BTDC when at 2KRPM
VSS - Showing 0MPH

Really not sure where to go from here. When I bought the car ~2 years ago the PCM had been replaced a year before that by previous owner. I have a reman PCM on the way and should be here Thursday. For the car to go from running just fine to throwing 3 of the 4 QUAD Driver codes makes me think short or bad PCM.

Thanks in advance for any help.

Drew

maxwedge
05-21-2019, 03:50 PM
One of the components driven by those quads is shorted or overloading the quad. Check the wiring in those circuits also.

DStyduhar
05-21-2019, 03:56 PM
Can someone tell me what sensors are controlled by each of those quads?

Doesn't it seem suspect that the car is fine and then 3 of the 4 quads fail? Cant imagine 3 sensors went bad at once. Maybe something common between sensors between quads?

thanks,

Drew

maxwedge
05-22-2019, 08:35 AM
You will need an oem manual for the in depth diagram from the pcm.

Blue Bowtie
05-22-2019, 09:17 AM
Some of the loads for the quad drivers on a '95 LeSabre/Park Avenue are:

Shift solenoid A
Shift solenoid B
Canister purge solenoid
Boost solenoid (supercharger)
Vent solenoid (cruise control)
Vacuum solenoid (cruise control)
Cruise lamp
Change Oil lamp
A/C relay
Generator
Coolant temp indicator
Volts lamp
EST control
EGR solenoid
TCC solenoid
WOT output (ride control)
Torque output (traction control)
Torque Level (traction control)

Not all vehicles have all these options.

Add your comment to this topic!