Weird smells.


Brandonb55
09-26-2018, 03:09 AM
Ok so I was driving home and all of a sudden I smelt what I can only describe as Vicks vapor rub, about 5 minutes later it turns into burning rubber that only lasted for a few moments. I was hoping someone would be able to help me with identifying what in the world just happened because I'm on my last leg with this car and about to take a sledgehammer to it due to piling on issues I've had with it since I got it.

wpbharry
09-26-2018, 05:06 AM
Year?

maxwedge
09-26-2018, 10:03 AM
Possible the odor came from outside the car momentarily?

Brandonb55
09-26-2018, 12:29 PM
Possible the odor came from outside the car momentarily?

Excessive heatcame from the car during the burning rubber and it started acting funny. It all passed when the smells did.

Brandonb55
09-26-2018, 12:30 PM
Year?

It is a 2006

Tech II
09-26-2018, 12:41 PM
A drop of oil hitting a hot exhaust will cause a smell like that....

Brandonb55
09-26-2018, 01:47 PM
Also, just found out I haven't had a injector fuse in my car since God knows when.

Brandonb55
09-26-2018, 01:52 PM
Also, just found out I haven't had a injector fuse in my car since God knows when.

Actually I'm missing quite a few important fuses. I've never had to get into the fuse box during the 2 years I've owned the car because it's always ran fine, until lately.

Tech II
09-26-2018, 09:08 PM
How in the world can a vehicle run without an injector fuse?

Which engine?

Brandonb55
09-26-2018, 11:25 PM
How in the world can a vehicle run without an injector fuse?

Which engine?

V6 3.something

wpbharry
09-27-2018, 05:52 AM
3.5 unless its an SS, in which case it's a 3.9. Sorry you're unhappy; our 2007 3.5 has been excellent. Previous owner may have been hard on it.

Tech II
09-27-2018, 08:40 PM
3.5/3.9 both use inj fuse 5(underhood fuse block) for injectors and fuel fuse 25(rear fuse block) for the pump.....No way can the car run without it....

Brandonb55
09-27-2018, 09:29 PM
3.5/3.9 both use inj fuse 5(underhood fuse block) for injectors and fuel fuse 25(rear fuse block) for the pump.....No way can the car run without it....

I'm dead serious, I'm matching diagram with placement and it's missing. It will run just not 100% because it doesn't close the circuit Wich would explain the random drop in rpm's and weird idle

Add your comment to this topic!