Possible Electrical Issue?


Alc00b
05-18-2017, 05:24 PM
For the past 3 weeks my car has just randomly refused to start. It's a 2010 Tahoe. I've had it towed twice with the first diagnosis of a new starter and the second that the main "bus line" was loose. It drives fine and then without warning will just not start back up. Lights and accessories all work, just no engine turn over. I have noticed that the Bluetooth stops working and randomly a power mirror won't fold in but then after restarting it's fine. Until it's not and it won't crank at all. Any ideas on what else could be the issue?

j cAT
05-26-2017, 11:26 AM
For the past 3 weeks my car has just randomly refused to start. It's a 2010 Tahoe. I've had it towed twice with the first diagnosis of a new starter and the second that the main "bus line" was loose. It drives fine and then without warning will just not start back up. Lights and accessories all work, just no engine turn over. I have noticed that the Bluetooth stops working and randomly a power mirror won't fold in but then after restarting it's fine. Until it's not and it won't crank at all. Any ideas on what else could be the issue?

what is a bus line ? sounds like B/S.. check for loose fuses should be set in place very very tightly.

aleekat
05-26-2017, 12:58 PM
Had a car once that had battery cable corrosion deep inside the cable not at the ends. Had the same symptoms for 3 yrs. Finally replaced the cables and never an issue since.

Add your comment to this topic!