No Heat!


cshults
12-15-2016, 05:35 PM
Hi all,

I encountered a heating issue with my 2001 Bravada today, the problem: there is no heat...well, very limited heat and only from the defroster.

The heat was working fine yesterday but when I went out today, no heat from the lower vents, no heat from the dash vents, and only slightly warm air from the defroster.

The temps did get very cold overnight and stayed that way all of today with a high of only 15 degrees...could something have frozen up? As I said, heat was fine yesterday, blew very hot and 24 hours later, nada.

The vent controls are operating without issue, I can switch from the lower/footwell vents, dash vents, blend, or defrost without issue.

Too cold and dark to check anything tonight, but what are some things I should check for tomorrow in the daylight?

Thanks for your suggestions!

Chris Stewart
12-15-2016, 07:33 PM
Hey Chris, does the engine get to normal running temperatures, on the temperature gauge?

cshults
12-15-2016, 07:35 PM
I should have mentioned that in my post, but yes, the temp is normal, holding steady, and not overheating.

Chris Stewart
12-15-2016, 07:51 PM
Score, but it ain't pretty.
https://www.youtube.com/watch?v=WiwZeJlAQdo

cshults
12-15-2016, 08:14 PM
Thanks for the link, Chris, good vid! But you're right, not pretty especially given the current weather outside!

cshults
12-18-2016, 03:01 PM
Update: The temps warmed up a bit yesterday, ~35* and the heat worked fine..so the actuator is still working but maybe there is some moisture/condensation within the housing that froze up one of the gears or something else froze up causing the no heat issue..

Add your comment to this topic!