Ticking, loss of power 99 Regal LS


Jrcarswell
09-10-2016, 08:11 AM
My Regal makes a ticking noise from the front left and when accelerating it can't go past 2-2.5k rpm. when the spark plugs were pulled they were running lean. Is this a fuel, spark or electrical issue or is the internal?

maxwedge
09-10-2016, 08:30 AM
Ticking noise from the engine? CEl on, any codes? Not enough info here.

Jrcarswell
09-10-2016, 11:10 AM
There is no CEL, No codes, the noise doesn't sound like a knock but more like detonation, spark knock or lifter tick. increases with speed and i can smell gas when i open the oil fill tube.

maxwedge
09-10-2016, 01:34 PM
Tough to diagnose from here, for sure don't run it with contaminated oil. Sounds like you are running so rich fuel is getting into the oil, high fuel pressure, bad fp regulator, one or more bad injectors, clogged cat, are possibilities.3800 or 3400?

Jrcarswell
09-10-2016, 05:25 PM
3800 Series 2 VIN K. I have 2004 Lesabre for parts. I put a screwdriver up to each injector and the pulse is fine but i know that doesn't tell everything so i pulled the fuel rail from the Lesabre. EGR Valve, Coil packs, whole exhaust system. I'll pull the fuel pump out tomorrow if this doesn't solve it

Tech II
09-10-2016, 06:01 PM
Try this LIGHTLY accelerate from a dead stop.......if you can get the vehicle up to 50 mph gradually, and the car shifts ok, then stop......

Now from another dead stop, REALLY LAY INTO THE ACCELERATOR.....if the car bogs down, doesn't upshift, and rpm's top out at 3K, chances are your cat if plugged.....

You can verify this by creating an exhaust leak between the exhaust manifold and the exhaust pipe(loosen the flange nuts so there is an air gap/leak)...the exhaust will be noisy.....lay into it from a dead stop, if you now have power back and it shifts ok, it's the cat....

And remember to fix whatever caused the cat to go bad, like a misfire, bad O2 sensor, etc.

Jrcarswell
09-10-2016, 06:39 PM
It lightly accelerates fine. shifts perfect. when i laid into the throttle it didn't go past 2500rpm. i'll try loosening the flange nuts next and see if that works. thank you very much

maxwedge
09-10-2016, 08:42 PM
Or remove the egr.

Jrcarswell
09-11-2016, 05:35 AM
Will removing the EGR valve have any negative effects?

Blue Bowtie
09-11-2016, 08:35 AM
Remove the EGR as a method of releasing exhaust gas. it will be temporary ONLY, just like loosening the exhaust flange (if you can loosen the flange without breaking studs it will be impressive).

In order to prevent damage to anything keep wiring and hoses out of the way of the EGR port when test driving.

Incidentally, that "tick" could under load also be an exhaust leak.

Jrcarswell
09-11-2016, 05:09 PM
Well. i tried all of the above and i even took the heads off and it doesn't look like i can find a diagnosis. CEL finally came on and it said map sensor so i replaced it. its better but it is still knocking and doesn't want to accelerate, not as bad as it used to be but still bad. engine is overheating and smoking. noise increases with rpm

Jrcarswell
09-11-2016, 05:37 PM
Well. solved it guys. it's piston slap.

Add your comment to this topic!