idle haywire when you turn on AC


NHRA
06-24-2016, 12:12 AM
2000 blazer 4.3 2 wheel drive auto trans ...........anyone ever seen this problem?
idle haywire when you turn on AC, idle jumps up 500 to 1500 rpms
had it at 2 shops don't want to mess up when it goes to the shop
have had the smoke test done, replaced ivac , tps ,temp sensor, mass air flow,
first time it went to the shop, they told me the intake gasket was bad had that fixed
shows no codes? now as soon you turn the ac on 80% of the time it will act up.
and even if you turn it back off it still acts up for along time.
ive done some research but cant find my problem, ive read that the reveits on the Throttle Body get loose but mine are fine, the mech from the shop said it could be the ECM?
thanks guys <<<<<<<<<<

NHRA
06-24-2016, 08:58 PM
anyone?...........................cheers

NHRA
06-26-2016, 07:01 PM
where have all the good mech gone? this site is dead use to be help everywhere now I see no one? just saying

NHRA
06-28-2016, 10:27 AM
ok after 4 days no replies?...............sites not what it use to be ....delete my act<<<<<<<

aleekat
06-28-2016, 10:51 AM
I'll ask the obvious. Had any a/c work done lately?

NHRA
06-28-2016, 11:52 AM
I'll ask the obvious. Had any a/c work done lately?

no I haven't just one day the idle started acting up and I found out it did it when you use the ac, but would still act up after ac was turned off for awhile then would be ok again
till you turned the ac controls to on....................thanks<<<<<<<<

maxwedge
06-28-2016, 04:08 PM
Make sure no has fooled with the base idle on the throttle body, also a scan with a good scanner will allow you to look idle control activity, I assume no codes? Also make sure no air is getting in behind the maf.

NHRA
06-28-2016, 08:58 PM
Make sure no has fooled with the base idle on the throttle body, also a scan with a good scanner will allow you to look idle control activity, I assume no codes? Also make sure no air is getting in behind the maf.

no one has touched the the idle and right no codes
new maf no leaks had mech do smoke test with no leaks................thanks

Add your comment to this topic!