2005 Altima no acceleration


Prof_h
06-22-2016, 05:33 PM
Hi,
Was hoping someone could help with this problem...
2005 Altima SE 3.5L, 70k miles, starts and idles fine, but will not accelerate when the gas pedal is pushed. Does not matter if it is in p, n, r, or d. I did turn on the A/C and got pulsing acceleration, rpms went up past 3k, but now I can't even do that. Had the car in storage for a year and was running perfectly before I put it in storage. The battery was dead when I went to get it out of storage, so I charged it and put it back in the car and it started up, idled fine, but then went to drive it down the road, it wouldn't go above idle speed. I did replace the fuel pump, but that was not the problem, it still has no acceleration above idle.
I looked at the air filter and all the air intake areas, no nests from animals and no evidence of chewed wires.
Can anyone offer any advice?
Thank you. :rolleyes:

MikeCStig
06-22-2016, 06:34 PM
Does your car have an all mechanical/cable operated throttle or some electronic Throttle-by-wire system?

Crvett69
06-22-2016, 08:56 PM
2005 altima should be a drive by wire system. will need a scanner/code reader to determine if its the throttle pedal part or the motor on the throttle body acting up. can also plug and unplug the throttle body plug, had one on a maxima doing same thing and plug was not making a good connection. also the alternator was only putting out about 12v so car was running out of voltage to run on

Prof_h
06-23-2016, 12:43 PM
Thank you to the both of you for responding. There is an electronic box under the gas pedal, so I guess it is electronic wire type gas pedal.
Today I noticed a lot of acid erosion around the bottom of the battery, perhaps the alternator is overcharging and causing some electronic problem? This car has never given me any problems, but it is over 10yrs old and probably could use some new parts.
I tried turning on the A/C and headlights while the motor was idling, I was then able to get the rpms at a steady 2k, but if I tried for more, I would get pulsing up to 3k then back to .8k.
After I turned off the motor, I heard a hissing sound coming from the battery vent ports and noticed all the acid below. Perhaps I am having a voltage problem?
I read on other posts something about a voltage regulator and how if it is not working, your car will not be accelerating properly.
I'm pretty sure this job is beyond my ability. The alternator is located in a very tight spot. The radiator may need removal, etc... I might as well get everything replaced. I haven't had this car in the shop for anything, so I am nervous, but I do realize my limits. :banghead:

Crvett69
06-23-2016, 04:04 PM
if you have a voltmeter you can check the battery voltage while it is running, should be be 13.3-13.8 while it is idling. if it higher than that it can boil the battery dry and if its lower some of the electronic parts may not work right

Prof_h
06-27-2016, 01:56 PM
Thank you, I'll try it.
:smile:

aleekat
06-27-2016, 03:01 PM
Since you had to charge the battery out of storage. How old is your battery?

Prof_h
06-27-2016, 07:28 PM
I'm back. After checking the voltage when the car was running, from the battery terminals, it seemed very high...18V.
I disconnected the alternator, then checked the voltage again...12-13v.
The car ran great, took it out for a spin, no hesitation, all the power, acceleration I need, up down hills and everything.
Glad to have this forum and all the help. Now, I'll be getting the car fixed. At least I can drive it to the mechanic.
Your question about the age of the battery...I purchased it in May 2015, so it is pretty new.

Crvett69
06-27-2016, 07:58 PM
have him check the battery, overcharging it can boil it dry

Add your comment to this topic!