Page updated on 08-19-2018

89 F150 eec relay problem


yekrats
08-09-2015, 01:04 AM
Ok, got an 89 F150 4.9L (300) straight 6, 5 speed w/dual tanks. Was driving along, switched to tank 2 just to kick it up a little, switched back and after a minute the truck died. Figured out it was no fuel getting to high pressure pump. Switched back to tank 2, still no run. Towed home and investigated. Bypassed fuel pump relay, took right off. Discovered fuel relay not being turned on by EEC relay. Bypassed EEC and ran fine. Discovered EEC relay had 12v power but not getting a (-) ground (being turned on) from EEC. Ground it and everything works fine. Had this same problem a month ago for about 5 minutes, then fixed itself. No problem again until now. Hasn't fixed itself this time. So... ? It's not the fuel or EEC relays, not a power problem, not wire connectors, no corrosion, just no (-) from EEC. Ummm, I haven't pulled the drivers side kick panel and checked the EEC yet. Next on the list I guess.

So, anybody ever heard of this? Am I missing something? Also, if I do just disconnect the (-) lead from the EEC relay and run a ground wire to make it work, will that hurt anything?

Update: I'm not too smart sometimes. When I turn the key on I hear the fuel pump run for 2-3 seconds so the relays have to to be working. Not sure why it seemed like they weren't but they are so all must be well. This leads me to believe the fuel filter must be plugged up. It was new around 5k ago but it's an old truck and the tanks could be full of crud so... I'll change it and see what happens.

Update 2: Discovered it was the fuel pump going out. Sometimes it still worked a little and the truck would run but after a while it quits. Just an old worn out fuel pump.

Add your comment to this topic!