Page updated on 06-24-2018

2005 suburban 4x4 issues


Tim W
03-28-2015, 09:03 PM
Hello,
No messages. 4 low works well. 2 high works well. Will not go into 4H and 4A.
When in 4 low and switch to 4H it will go into 4A and work. I have replaced dash switch and actuator. Did not help.Any help would be great.
Thank You
Tim

j cAT
03-29-2015, 07:18 AM
Hello,
No messages. 4 low works well. 2 high works well. Will not go into 4H and 4A.
When in 4 low and switch to 4H it will go into 4A and work. I have replaced dash switch and actuator. Did not help.Any help would be great.
Thank You
Tim

surprised no 4wd error message.

improper switching is the encoder not the actuator ...
the reason these do cause problems is , the fluid need be changed every 40K miles. the trac II transfer case fluid must be a nice clean blue color .

never use 4wd in any position on dry solid pavement. avoid using locked 4wd. use auto 4wd as it puts less stress on the drive train.

tus00637
03-31-2015, 02:42 PM
surprised no 4wd error message.

improper switching is the encoder not the actuator ...
the reason these do cause problems is , the fluid need be changed every 40K miles. the trac II transfer case fluid must be a nice clean blue color .

never use 4wd in any position on dry solid pavement. avoid using locked 4wd. use auto 4wd as it puts less stress on the drive train.

Good info j cat. My wife's 2005 Suburban was giving the service 4wd message every once in awhile with no other symptoms. Transfer case oil was changed per manual at 100,000 miles. All 4wd functions worked fine so I just recently changed the push button selector switch out. We'll see if that takes care of the service message. Seems good old GM has had a lot of issues with this system on mid 2000 vehicles.

Add your comment to this topic!