Page updated on 12-14-2017

94 chevy caprice classic ls


chuckd317
09-02-2014, 08:31 PM
I have 94 chevy caprice classic LS with a lt1. it starts up just fine put it in gear and it want to cut off put it in neutral or park just fine. while driving it want to back fire cut off the whole nine yards had to give it gas in order not to cut off but now that's starting not to work thought it was the converters being clogged since in a heavy rain was forced to drive in a lake of high water (was know way around it driving in gurnee and grate lakes IL, two lane high way trucks and cars around no choice every one there had to drive through it) any ways haven't worked right since. took the converters off still same thing, changed plugs and whires same thing fuel filter same thing. check engine light pops on and off but some time problem happens and it dont come on. What could it be???????????? tired of it just need it to work or ima sell it

j cAT
09-03-2014, 07:54 PM
I have 94 chevy caprice classic LS with a lt1. it starts up just fine put it in gear and it want to cut off put it in neutral or park just fine. while driving it want to back fire cut off the whole nine yards had to give it gas in order not to cut off but now that's starting not to work thought it was the converters being clogged since in a heavy rain was forced to drive in a lake of high water (was know way around it driving in gurnee and grate lakes IL, two lane high way trucks and cars around no choice every one there had to drive through it) any ways haven't worked right since. took the converters off still same thing, changed plugs and whires same thing fuel filter same thing. check engine light pops on and off but some time problem happens and it dont come on. What could it be???????????? tired of it just need it to work or ima sell it

these engines have a distributor that gets wet too easy. driving in water is not recommended meaning no deep puddles...this OPTI distributor has a venting harness. remove the lower vent hose see if water comes out ..if so you will have to replace it. not a fun job.. expensive..engine light flickering on off says miss fires that then says you got a wet distributor at the least...most likely new is required and recommended with all the work to get it out...........

Blue Bowtie
09-04-2014, 04:30 AM
Second vote for an Opti cap and rotor at least. If you are fortunate you can dry out the optical array and clean the interruptor discs. It would be a good odea to verify that the Opti vent system is connected and functional. It consists of a couple vacuum hoses and a check/flow valve. It will greatly extend the life of the system. Only the B and D bodies had the vent system in 1994, but all other LT1s got it in years thereafter.

Add your comment to this topic!