'06 SV6 - 3.5 max rpm under in park??


sisson_d
08-22-2014, 08:02 PM
I'm trying to diagnose an intermittent problem that's not throwing any codes. Today, while recording data to a scanner, I was trying to see if all the numbers looked normal while revving the engine. One thing I was looking at was whether the accelerator pedal position sensor worked. About 2/3 of the way toward the floor, the RPM's stopped rising at 4,015 rpm. If I floored it, the RPM's would peak around 4,000 and then it would slowly lurch down towards 3,500 like it was losing power.

Now I know that I've seen it much higher when driving with the AWD disabled (shift points are off w/o AWD enabled). But are the RPM's limited when in park?? Can someone else with this engine check this?

Also, while floored, the scanner showed the pedal sensor acting normal and at 100%, plus the Absolute Throttle Position and Calculated Engine Load were both reported at 100% at the time. Even when the RPM's would drop down towards 3,500.

I'll post the stats from the scan in the next post.

sisson_d
08-22-2014, 08:25 PM
Nevermind, it seems normal since I tried 2 other cars and they all had lower RPM limiters in Park. I'm guessing it's to protect the engine and drive train for when it's put in gear. I'm still surprised that it shows 100% throttle and load though even if limited.

1999montana
12-04-2014, 10:10 AM
The fuel delivery system has a cut-out to prevent over-revving in neutral or park. Max's out at about 4,000. The engine will chuggle and the RPM's will drop off below 4,000.

Add your comment to this topic!