Our Community is 705,000 Strong. Join Us.


Odyssey theft protection radio problem


pageboy
06-28-2003, 12:48 PM
My 2001 Odyssey had some repairs made and the radio was without power for a few days. When everything was powered up the radio flashed the proper error message "code" for a day or two. When I got around to finding the proper 5 digit code to clear the security system there was a big surprise!! The display is now BLANK and the code cannot be entered. The security light is blinking but there is no screen display and no response to any knob or button.
What can cause the display to be blank?? Is there a security system reset needed if the code isn't entered timely?
Thanks,
alan

lorunner
07-05-2003, 03:55 PM
try disconnecting the battery for a minute and reconnect and put the code in and see what happens.

pageboy
07-14-2003, 09:42 AM
My radio is feed from two sources. The majority of the supply come thru the "radio" fuse but it seems that the panel display is feed thru an "aux" fuse. That fuse was blown by a hand vacuume plugged into the outlet in the back of the van. With no power to my radio display I could not enter the code. All is OK now.

chetan
06-19-2005, 07:04 AM
Hi,

This is good information. It seems I may have similar problem on my radio. Would you know the location of AUX Fuse? I tried finding it but could not locate appropriate location.

Thanks for your response.

REgards,
CM


My radio is feed from two sources. The majority of the supply come thru the "radio" fuse but it seems that the panel display is feed thru an "aux" fuse. That fuse was blown by a hand vacuume plugged into the outlet in the back of the van. With no power to my radio display I could not enter the code. All is OK now.

michelle362436
01-24-2007, 04:25 PM
I have a 2002 Odessey & am having the same radio problem (not responsive) but I do not see an AUX slot on any of the fuse boxes. Can anyone tell me where this might be or what to do about this radio. I just read to disconnect the battery so I'll try that while waiting for a response.

Thanks!




Hi,

This is good information. It seems I may have similar problem on my radio. Would you know the location of AUX Fuse? I tried finding it but could not locate appropriate location.

Thanks for your response.

REgards,
CM

240slider
03-17-2007, 09:58 PM
the fuse you are looking for is on the passenger side kick panel

bcocozza
03-02-2008, 01:47 PM
I am experiencing the same problem with my radio in my 2002 Odyssey. It suddenly stopped working and I have checked fuses under the hood and disconnected the battery. No luck so far. It still does not ask for a code. Which fuse worked for you guys? I heard someone say check the passenger side fuses. help.

bcocozza
03-02-2008, 08:41 PM
Thanks guy. I checked passenger side fuse box and found the blown fuse you stated. My radio is working again.

Thank you.

winelover
02-01-2009, 06:45 PM
I have a 2003 Odyssey. I had the transmission rebuilt. The battery did die. Everything in the car works except the radio. It has never come on to put in the codes after the battery initially died... I did wait awhile to replace the battery. I got the car back on Friday night and have driven it 3 times since then. Do I need to wait longer or try something else.... ? I have check the fuse and it is fine.

Thanks
Kim

ckay77
09-17-2009, 10:59 AM
Thanks for the help! Checking and replacing a 15amp fuse on the passenger side fuse panel on my 2001 Odyssey did the trick. One note though: the fuse was labeled Accessories not Aux. It was located on the top right of the panel.

Chris

Add your comment to this topic!