Page updated on 11-22-2017

Tyre degradation Revival International


richardinitaly
05-16-2014, 11:53 AM
First time poster here. I did a search for this but didn't turn anything up so here goes. Over the last few years I've made a number of Revival International (Bologna) kits. The C Type Auto Union, P3 Alfa, Auto Union Record car, Ferrari 500 F2, Ferrari 156 F1 and I'm about to embark on the Ferrari Lancia D50. They're generally very satisfying kits to build, take quite a lot of thinking out and occasionally can be difficult to fit however the outcomes are splendid. My gripe is the way that the tyres are falling apart, see pics. The F2 500 I only built 2 years ago, the tyres on the Auto Union were replaced the year before. I'm sorry but a kit that costs what it does and takes so much building should last longer than that. Before I email and tackle the company in Bologna can anybody tell me if I'm doing anything wrong. As far as I can see you just roll the tyres onto the rims, nothing else. Anybody else had the same experience? Oh and by the way the models are in a relatively cool part of the house with no direct sunlight at all. Any help much appreciated.

bmwh548
05-16-2014, 12:15 PM
I can't see the pics so I don't know exactly what's happening but in the past I've had issues with the tires whenever I used automotive paint for the rims (the solvents take a lot of time to completely "dry"). Is it possible that the paint wasn't 100% cured when you put the tires on?

gtziaf
05-16-2014, 02:31 PM
Hello, I have a similar problem with my 625.
http://www.automotiveforums.com/vbulletin/showthread.php?t=978429

I think the problem is the metal part inside the tyres. Especially in hot days the metal part warm the tyre, so after some time, it destroys it. I glued mine, but in next one I plan to cover this meal part, with some tape...
Hope it helps...

RonCla
05-16-2014, 10:00 PM
The tires on my Auto Union I built way back in the early 1980s are still perfect but the white tires on my Fiat F2 came apart not long after I had built it.

I have read on other forums about tire issues with these kits.

http://i1173.photobucket.com/albums/r589/Roncla/IMG_2126.jpg (http://s1173.photobucket.com/user/Roncla/media/IMG_2126.jpg.html)

richardinitaly
05-17-2014, 04:20 AM
Thanks for all those responses people. Sorry the pics didn't work. So at least it looks like I'm not the only person with this problem. RonCla, your Auto Union hill climber is very nice. Guess that's Hans Stuck? That was the first model I bought from them way back in the 80s. When it was the original Revival company. Tyres on that lasted quite a long time but I replaced them recently when I converted the car to a GP Type C. Those tyres are already toast! I'll get an email and some pictures off to the company and let you know their response. Ciao.

Add your comment to this topic!