Page updated on 08-19-2018

99 suburban instrument panel


strawbery
03-16-2014, 06:45 PM
ok I have a 99 GMC suburban when you first turn the key on but not to the point the truck starts there is a clicking that happens and it does it 4 or 5 times and while it does this the fuel gauge goes crazy moving from empty to full very fast several times, the other gauges move to but not to that point, once the truck is started the gauges may or may not work except the AMP and the oil they seem to work the speed o and the tac work but not right the speed o is not accurate sometimes seeming to be maybe 10 to 15 mph off and the tac doesn't drop when the truck shifts or ride where it should anybody got any ideals the gauges worked when tried in another truck

Jean Cohen
03-20-2014, 09:36 PM
With the panel loose there are switches that need to be disconnected. The headlight switch connector has a locking tab that needs to be depressed before the connector can be removed from the switch.

j cAT
03-22-2014, 09:38 AM
ok I have a 99 GMC suburban when you first turn the key on but not to the point the truck starts there is a clicking that happens and it does it 4 or 5 times and while it does this the fuel gauge goes crazy moving from empty to full very fast several times, the other gauges move to but not to that point, once the truck is started the gauges may or may not work except the AMP and the oil they seem to work the speed o and the tac work but not right the speed o is not accurate sometimes seeming to be maybe 10 to 15 mph off and the tac doesn't drop when the truck shifts or ride where it should anybody got any ideals the gauges worked when tried in another truck

I would check the ignition switch .with a meter check for voltage issues with the key to ignition on ...

Add your comment to this topic!