Page updated on 11-18-2017

Need help asap!!!


5spdstang
07-31-2013, 08:12 PM
Well...I've been struggling badly over the last few months on my project, i finally got around to laying down the paint.....Cleared it, polished it, foiled it......and now FKD IT!! :crying:

I used tamiya X11 silver on the lock cylinder detail, fine..carried on with other tasks..but noticed that i somehow managed to make contact with it and smudged it!! I tried to wipe it off gently with tamiya thinner, all it did was smudge it and ive now fkd up a perfect paint job:banghead:

Is there any way i can remove this without having to strip this? i cant believe a waterbased paint wont come off!!! The clearcoat is spraycan lacquer and the paint under it is nail polish.

please excuse the terrible cell shot of the smudge.

....So upset right now.

https://fbcdn-sphotos-f-a.akamaihd.net/hphotos-ak-ash4/999710_10151751053761418_2135642389_n.jpg
https://fbcdn-sphotos-g-a.akamaihd.net/hphotos-ak-ash4/p206x206/999059_10151751311796418_359232667_n.jpg

Fangi0
07-31-2013, 08:21 PM
If it's dry it should just buff off with a bit of Tamiya compound, or any similar compound with a 'cutting' agent in it...

It will literally be sitting on top of the polished / painted surface. It should have 'etched' it's way into the paint below...

Even toothpaste would probably work....

5spdstang
07-31-2013, 08:26 PM
If it's dry it should just buff off with a bit of Tamiya compound, or any similar compound with a 'cutting' agent in it...

It will literally be sitting on top of the polished / painted surface. It should have 'etched' it's way into the paint below...

Even toothpaste would probably work....

I hope youre right, god..i feel so stupid, I was trying so incredibly hard NOT to do something like this..and i did anyway!!

I have tamiya compound...gonna try it now!

5spdstang
07-31-2013, 08:31 PM
...not working...just shining it up!!!

5spdstang
07-31-2013, 08:37 PM
What the hell do they put in this paint?? Its supposed to be waterbased, easy cleanup, yet NOTHING removes it!!! im rubbing like crazy with turtlewax clearcoat polish and even it isnt working!!

5spdstang
07-31-2013, 08:47 PM
Just found some turtlewax rubbing compound.......... ITS WORKING!!!!!!

5spdstang
07-31-2013, 08:56 PM
Had to rub carefully but with resolve, but I got it off!!!!

http://www.gtbilprodukter.no/Customers/gtbilprodukter/images/bilder%20butikk/bilpleie/turtlewax_rubbing_compound_s.jpg

Keep this stuff handy, 1st time ive used it in 20 years..and it was still moist!

Thank god the problem is solved...Thanks for the help and quick reply Fangi0 (http://www.automotiveforums.com/vbulletin/member.php?u=322086), I used to live on the north shore of Auckland!! Eskdale rd :)

avd
07-31-2013, 10:43 PM
Geez keep on posting each step you do lol

tonioseven
08-01-2013, 02:14 AM
^^Lol.

Add your comment to this topic!