2009 Aveo


2dooreighty5
06-18-2012, 08:37 PM
hey guys im posting for my mom who has a 2009 chevy aveo...she bought the car in august 2009 and has put 20,000 miles on it since. Recently the mpg have declined and a bad smell has became noticeable after driving for longer than 15 minutes...the smell is similar to rotten eggs...on top of that problem...she has noticed that the car acts like it is going to stall sometimes and then doesnt and lurch's and drives like normal...just changed spark plugs and its still doing it...any ideas on what is could be...also anthing i can check...thanks guys!

GMCustomerService
06-19-2012, 06:02 PM
The rotten eggs smell, according to http://www.acdelco.com/auto-service/#VehicleSmells (which is not a GM website, and so GM cannot be held responsible for the information there), could be due to an emissions problem. There should be an emissions warranty on the Aveo - if you wanted to send me the last 8 of the VIN I could get more information on the specifics. Also, you could always contact your servicing dealership to find out more about the warranty.

Regards,
Sarah
GM Customer Service

gmtech1
06-19-2012, 06:49 PM
Sarah's on it! Sounds like a bad catalytic converter and may still be covered under emissions warranty. Either give her the info she requested, or contact your local dealer and provide the vehicle info to find out for sure.

2dooreighty5
06-19-2012, 10:19 PM
thanks for the response guys! we ended up taking the car to the dealership and they replaced the oxygen sensor and so far its running great...ill post back up in a day or two and see if things change...I figured it was either fuel pump or injectors or ya maybe something related to emissions...but o2 sensor sounds right..

Add your comment to this topic!