1996 sunfire 2.4L shifting problem 3rd to 4th gear


mega8man
06-09-2012, 06:35 PM
My sunfire is not shifting from 3rd to 4th gear. I will shift fine all the way up to 3rd and then ir revs like it is in neutral when i hit about 43 mph. it gets a little bit of a jump if i get off the gas all the way and then back on it and i can get it up to 55 but the rpm's are at 4.5. I read a few different posts that seemed like they may have had the same problem but they werent describing the way my car is acting. I went and got the fluid exchanged today and also changed the throttle position sensor on a whim because someone told me it could be the problem. Oh and if you couldn't have guessed by the post it is an automatic. :p
Any ideas or test i could do would be greatly appreciated. Thank you!

Tech II
06-09-2012, 08:08 PM
Were there any codes, like shift solenoids?

What was the condition of the old fluid? Did they find any metal in the pan?

Certainly sounds like an internal problem.......

mega8man
06-14-2012, 08:16 PM
Alright! I'm sorry it took me so long to reply. I have been working on getting my code reader to work since the port was a little screwed up on the car and i couldn't pull the codes. But now i have the codes. hah too bad i still dont know anything about transmissions.. well the codes i pulled were:

P0753 Shift Solenoid A Electrical

P0758 Shift Solenoid B Electrical

P1810 Manufacturer Controlled Transmission

P0113 IAT sensor 1 High Input

When I had the transmission fluid changed there were no metal shavings in the pan.

mega8man
06-15-2012, 06:30 AM
Does anyone know how difficult it is to diagnose the shift solenoids? I wouldnt know where to start or how to test them.

Add your comment to this topic!