97 Regal turn signal bulb always blowing.


caddiali
05-20-2012, 11:09 AM
I keep changing left turn signal bulbs..I installed one 3 weeks ago, and I got the fast clicking turn signal problem already (orange one). Im wondering if the bulb holder socket is blown. Any ideas/suggestions always appreciated!

Tech II
05-20-2012, 02:55 PM
Bad bulb? I mean the old one you had in there probably lasted a long time.....the replacement one could have been bad.....any water getting in the lense?

DeltaP
05-20-2012, 03:51 PM
I've had some bad sockets with bad contacts and high resistance cause alot of heat and short live bulbs. The water thing too like TechII says.

flightsmith
05-21-2012, 02:10 PM
I keep changing left turn signal bulbs..I installed one 3 weeks ago, and I got the fast clicking turn signal problem already (orange one). Im wondering if the bulb holder socket is blown. Any ideas/suggestions always appreciated!

This happened to me for like 4 or 5 bulbs within a month. What worked for me was a VERY SIMPLE fix. BULB GREASE. It's like $2 and I haven't had to replace one since. Good luck

caddiali
05-22-2012, 06:46 PM
I tried to tighten the socket terminals, adjusted them, but still no luck. So we are going to try replacing the actual bulb socket. I will update on the results

Thanks again

caddiali
05-26-2012, 11:16 AM
This happened to me for like 4 or 5 bulbs within a month. What worked for me was a VERY SIMPLE fix. BULB GREASE. It's like $2 and I haven't had to replace one since. Good luck

Thanks flightsmith, great advice....We put some silicone last night in the socket and the bulb is blinking and staying on properly.

Add your comment to this topic!