Radio Dead...sort of


kwaskow
06-03-2003, 08:58 AM
Hi, I am new to the forum, but own an old J30.

The radio will not come on, and hte display is not operating, but hte CD player happily accepts and ejects CD's. The tape player will do the same, as well as FF and RW tapes....but no audio from either and no power antenna when I try to switch over to the tuner mode of operation.

Any help is greatly appreciated!

Stranded in Iowa....with no radio

northernnate
06-19-2003, 05:33 PM
I just had the same exact problem, I had to get a new deck. They said it was getting power but the core was dead. I have a 94 J30. Be careful when you get a new deck, if you have a Bose system the speakers have amps attached and non-bose decks cause a light constant static. I can't hear it when I turn it up but at low volumes or between cd songs it bugs me. They said they would have to disconnect those amps on each speaker and it would be fine, I am dealing with it for now. Anyway, ask about it.

tiggermarty
10-27-2003, 11:14 AM
I'm sure by now you may have done something to fix the radio, but just wanted to let you know - I used these guys and my radio works fine now: http://www.carstereohelp.com/

they also provide a 1 yr warranty

Infinity300zx
12-05-2004, 10:28 PM
mine did the same thing but when i pull back on the key slightly it gets power, must be a loose connection but it turns on every time, i hope that works for your car as well.

Speedy_1234
12-10-2004, 05:06 PM
Well my Does not give light when in fm-am but when it in tape or cd the light goes on what is happeing to my radio

apensity
12-10-2004, 06:42 PM
Have it repaired. It's a small repair, took about $75 if I remember right. I sent it in and had it back working better than ever within a week. Easy to take out and install. Look for my past posts on this for the contact info for the shop I sent it to.

Hi, I am new to the forum, but own an old J30.

The radio will not come on, and hte display is not operating, but hte CD player happily accepts and ejects CD's. The tape player will do the same, as well as FF and RW tapes....but no audio from either and no power antenna when I try to switch over to the tuner mode of operation.

Any help is greatly appreciated!

Stranded in Iowa....with no radio

infinman
12-18-2004, 07:20 PM
infinity300zx: You have or are probably aware of , a bad ignition switch{electrical. Not key and cylinder}.Very common on J30's.The switch gets stuck between start and run after starting{doesn't return to run position}.

Speedy_1234
12-22-2004, 05:20 PM
on the light of the radio or with forum is this to

Add your comment to this topic!