Our Community is 705,000 Strong. Join Us.


02 ram 4.7L engine noise


budguy007
02-20-2012, 08:51 PM
I have a 02 Ram 4.7L with just about 100,000 miles thats got a slight engine noise when motor is cold. Once the motor warms up the noise goes away. I buddy of mine says its dirt on the oil feed to the timing chain and says to put a little trans fluid in the oil and drive it abit and then drain the oil. Any ideas of what the problem is and how to clean it. I dont trust putting trans fluid in the oil.

jamesslcx
02-21-2012, 02:26 PM
bud. I would try Marvel Mystery Oil or Risolone before trans fluid for a gentle cleaning. Run this for a while and change your oil with a good filter. I recommend using a Mopar filter. These engines are sensitive and pretty high tech and will not tolerate neglect. Since your engine only makes noise when cold it could be the filter also, hopefully nothing more serious. What kind of oil and filter have you been using? At what interval? Hope this helps.

DeltaP
02-21-2012, 06:48 PM
bud. I would try Marvel Mystery Oil or Risolone before trans fluid for a gentle cleaning. Run this for a while and change your oil with a good filter. I recommend using a Mopar filter. These engines are sensitive and pretty high tech and will not tolerate neglect. Since your engine only makes noise when cold it could be the filter also, hopefully nothing more serious. What kind of oil and filter have you been using? At what interval? Hope this helps.
:2cents: I agree, Tranny fluid does not lubricate.

lakefork
02-28-2012, 10:06 PM
i have a 03 ram 1500 4.7 it does the same thing its is probably the camshaft and valves dont know what to do about it since it goes away i would not worry about it

Add your comment to this topic!