Ignition switch button no response


tpjayaprakash
02-16-2012, 01:16 PM
I cannot turn on any power mode with ignition push button switch.
I already changed rcdlr, bcm, ignition push button switch.
Also Tech2 is not communicating with rcdlr.

GMCustomerService
02-16-2012, 02:52 PM
I'm sorry to hear that you are having difficulties with your ignition switch. I would be happy to look into this with you if you would like; please send me a private message with more information (include the last 8 digits of your VIN and the dealership you have been/would like to work with).
Regards,
Sarah
GM Customer Service

gmtech1
02-16-2012, 03:18 PM
What are you working on? Some vehicle info would be helpful. :)

tpjayaprakash
02-17-2012, 01:07 AM
thanks, today is holiday here in kuwait. Tomorrow i will send full details of the car

tpjayaprakash
02-17-2012, 09:22 AM
What are you working on? Some vehicle info would be helpful. :)
i am working on cadillac 2004 xlr.
It has a push button ign start button. I cannot turn on any of the ignition modes. Battery is ok. Already changed rcdlr,bcm, ignitioin switch. Rcdlr is not communicating with tech2. All positive, ground and data line to this module is ok.

gmtech1
02-17-2012, 10:18 AM
Are you SURE the battey is good? Has it been load tested? The RCDLR will not function if it sees less than 9v, Also has the RCDLR been relearned or was it replaced to correct your current condition? Are there any codes stored in the vehicle?

RCDLR had the theft relearn done?

tpjayaprakash
02-18-2012, 05:35 AM
Are you SURE the battey is good? Has it been load tested? The RCDLR will not function if it sees less than 9v, Also has the RCDLR been relearned or was it replaced to correct your current condition? Are there any codes stored in the vehicle?

RCDLR had the theft relearn done?
I changed 2 batteries, load tested, ok. Cannot retrieve codes because ignition on, accessories modes are not working. Also theft relearn canoot be done because ignition modes are not working.

gmtech1
02-18-2012, 11:39 AM
Just so I understand you, you can communicate with all modules, just not the RCDLR? If thats the case, check the ECM/TCM fuse #11 15amp under hood. Then check the power ckt, connector C1 terminal H, rred and white wire at the RCDLR. Then check the serial data wire C1 terminal L on the RDCLR to the BCM C1 terminal 55, Its a pink wire, make sure its ok.

tpjayaprakash
02-19-2012, 12:36 PM
Just so I understand you, you can communicate with all modules, just not the RCDLR? If thats the case, check the ECM/TCM fuse #11 15amp under hood. Then check the power ckt, connector C1 terminal H, rred and white wire at the RCDLR. Then check the serial data wire C1 terminal L on the RDCLR to the BCM C1 terminal 55, Its a pink wire, make sure its ok.

checked ecm, tcm fuses ok. checked power circuit at rcdlr terminal H,ok.
checked serial data wire c1 terminal L on the rcdlr.But it is going to splice pack, not to bcm C1 terminal 55. checked continuity from rcdlr c1 terminal L to splice pack, it is ok.

gmtech1
02-19-2012, 02:41 PM
Sorry, I missed the splice pack. The BCM wire at terminal 55 runs to that pack also, so check from RCDLR to BCM connector. Also inspect that splice pack for corrosion, those are all serial data lines. The wire at terminal 55 connector C1 shows to be light green.

Add your comment to this topic!