Our Community is 705,000 Strong. Join Us.


1G Throttle Troubles


RSLaser
02-09-2012, 02:11 AM
Well... maybe we'll get some input, never seen this place so dead...

Anyway, been working on the old laser for a few months now, new head, computer, 2 transistors(think it may be the culprit to my question), and other fixes, and finally got it driveable. However, when accelerating, the car does fine, unless you floor it. When throttle wide open, at around 4k it begins to lose power, almost like it may not be getting enough fuel. If you let off the accelerator, and slowly apply the gas, it will do fine-ish. The other day tried resetting the computer and took it for another drive, same thing, but then it even began to happen around 2-3k, then finally couldnt accelerate at all, then died. Restarted it and drove it home. Its a 91 Laser RS 2.0 NA.

Tried:
Changed TB
Changed IAC
Changed TPS
Adjusted Throttle cables
Changed out the ign transistor twice
Removing gas cap
Fuel additives
Spark plug/wire replacement
New fuel filter
Fuel pump/screen about 6 months ago

The only "mod" that I did was the TB coolant bypass, and seriously doubt that would cause such an issue.

The computer is also out of a '94 I believe(had to replace it anyway)

Think that about covers it, Ive researched it and tried quite a bit, I keep getting pointed to the ecu and transistor. Thoughts?

Add your comment to this topic!