Our Community is 705,000 Strong. Join Us.


getting tough to start??


bwhntr4168
02-03-2012, 08:35 AM
ok guys now, i bought this truck only a few weeks ago? it seems harder and harder to start??runs fine when started? its a 96 w/throttle body!

ricebike
02-03-2012, 10:39 AM
start w/ the basics

battery load test,

cables to battery, ground wires...

j cAT
02-03-2012, 06:48 PM
ok guys now, i bought this truck only a few weeks ago? it seems harder and harder to start??runs fine when started? its a 96 w/throttle body!

what engine ? throttle body injection ? poor start means engine cranks good ? does not run .

this can be the engine coolant temp sensor on the intake manifold. also make sure the vacuum is good no leaks. especially the throttle body base area.

bwhntr4168
02-04-2012, 06:09 AM
what engine ? throttle body injection ? poor start means engine cranks good ? does not run .

this can be the engine coolant temp sensor on the intake manifold. also make sure the vacuum is good no leaks. especially the throttle body base area.

4.3 4x4 throttle body, cranks good but takes some time to start ? all new plugs wires cap and rotor!

ricebike
02-04-2012, 11:34 AM
since the battery cables are good & the battery is healthy, fuel filter?

EZFrank
02-07-2012, 11:29 AM
did you check make sure your getting spark and fuel i had some issues with my 96 s10 and changed out bunch of stuff and still would not start i thought fuel pump which i did a few times thinking they where defective and found that i was getting no pressure at the pressure regulator and changed it out and solved my problems check your computer for codes i had P0300 cylinder misfire.

Add your comment to this topic!