Our Community is 705,000 Strong. Join Us.


code po405 po716 po717 po405


driscollcolin
02-01-2012, 07:09 PM
I have a 2003 aztek with 125000 miles check engine light came on got four codes po405 po716 po717and po405 in this order the only prob i have is maybe one a week when i start the car and accelerate in to go forward it takes two or three seconds however it only dose this when i first start it in the morning.


thanks for you help

GTP Dad
02-02-2012, 09:20 AM
The P0405 code indicates a problem with the EGR valve. It may be bad or dirty. You can remove it and clean it with throttle body cleaner. Make sure the tube to the EGR is not blocked. As for the other two codes the it indicates a problem with the speed sensor in the transmission. They do go bad and you should probably have it replaced. This will cure some of your issues when driving.

Tech II
02-02-2012, 10:16 AM
Definitely looks like two seperate problems....

Trying to remember if there was a TSB on this problem, but it should have been fixed by now........it was about the EGR freezing, and which EGR you had, top connection or side connection(Siemans)......in the tsb, you had to replace the EGR and harness, depending on which EGR you had.....

However, this code is usually about the pintle position sensor....

As for the other two codes, could be the speed sensor, the wiring to it, or the PCM....

In both cases, the only way to know for sure is with a scan tool....

driscollcolin
02-02-2012, 11:46 AM
thank for help talked to a friend who is a auto tech he said clear code drive car leave scan tool on and see what codes come back on did that and got po405 so he said replace egr valve and pray he said he seen it throw the po7117 and po717

driscollcolin
02-15-2012, 06:05 PM
now i have code po401x2 has a miss fire once and a while i took out spark plug it is white thinking needs new o2 sensor it has 120000 miles

Add your comment to this topic!