Our Community is 705,000 Strong. Join Us.


95 ram won't start


mxz600
11-22-2011, 01:44 PM
95 ram, 3/4 ton, 4x4, 5.9 gas -

I have searched all over and can't figure out what to do next. Here is what has happened so far.
Within the last year, plugs/cap/rotor/wires/coil were replaced.
Truck ran one day, wouldn't crank the next. (put a new starter on, good to go).
Next day it fired right up and then died a couple minutes later. Would not refire without
the use of starting fluid.
Next day, got a fuel pressure tool and read 30PSI when key on and fuel pump ran. After
fuel pump shut off, pressure dropped right to zero (must be a bad fuel pump).
Ordered a new fuel pump and installed. Truck fired right up and then died within
30 seconds. Would not refire even on starting fluid.
Cranks and cranks and cranks so it's not the battery(even tried a new one) and it's not
the battery connections (clean and tight).
I scoured the internet for a crank position sensor location, but this thing doesn't have
one where they say they should be.

What to do next?

Thanks,
Jay

Chris Stewart
11-22-2011, 06:49 PM
Check this,

http://www.justanswer.com/dodge/4cllz-dodge-ram-1500-4x4-crankshaft-sensor-located.html

mxz600
11-23-2011, 05:12 PM
Local repair shop says pickup coil is bad and will have it done Friday for me.
There goes another buck forty.

Jay

Chris Stewart
11-23-2011, 09:03 PM
Thanks for the update.
Sometimes I have to let a Pro look at my stuff too.

mxz600
11-24-2011, 08:37 PM
Yeah Chris, I give in when it's over my head and I hate looking up stuff and not seeing replies of what fixed it. Just glad to get the old girl back before the snow flies.

Jay

Add your comment to this topic!