96 Oldsmobile list of problems


wwepatriot
11-21-2011, 02:45 PM
Its a 4 cylinder Cutlass Ciera 1996.

One thing to note the is the plugin to the Transmission Torque Solenoid is off, the solenoid itself needs to be replaced.

Problem #1 - Sometimes when accelerating from stopped position, the car stumbles to go and act like it wants to kill until I push the Accelerator harder. It will only do that at low speeds, once up to speed its ok (this a possible fuel problem somewhere?


Problem #2 - Heat is coming out of the vents when heater and all is off, perhaps this is a minor problem, once I start turning AC or heater on and off, it will stop.


Problem #3 - This could be releated to problem #1, from cold start, the car hesistates to go on acceleration from stopped or parked point, after the engine warms up for about 10-15 mins of driving, the problem goes away, I thought one point I had a bad motor mount, perhaps its a sensor?

maxwedge
11-21-2011, 04:18 PM
Which solenoid? Also have had it scanned for pending codes, many things can cause what you describe, low fuel pressure, o2 sensor, tps, maf if so equipped.

wwepatriot
11-21-2011, 04:24 PM
I guess its the Torque Converter Solenoid, thats the one that is unplugged under the hood. Solenoid is still there, but the wire plug that plugs into it under the hood, is unplugged, been like that for about 8 months.

I never did find any codes worth mentioning although could scan again, one I know was position throttle sensor, and that was a new sensor though, but its always keen on throwing that one.

maxwedge
11-21-2011, 08:20 PM
You need to focus on a tps code, that can cause trans shift issues, idle speed issues, throttle response.

wwepatriot
11-25-2011, 04:48 PM
P0122 seems to be a code that come up alot, but the sensor was changed and it would still throw the code.

It also throws P0113, P0140, and P1520, but the 1520 has always came up for years.

of those codes, all but the 0122 could not be deleted off the computer.

Upon trying to delete P0122, the card idle low like it was trying to delete the code but failed to do so.

maxwedge
11-25-2011, 04:52 PM
A scanner can look at the tps inputs to the pcm, look at the wires in the connector, make sure one is not pulled back or bent.

wwepatriot
11-25-2011, 05:34 PM
ok heres what I have done, no idea if the problem is going to go away until I travel the distance of 20-25 miles though.

But upon trying to get rid of Code P0122, I went ahead and put the old sensor on, the one that was on was a new one from NAPA (bad parts dealer IMO anyway) and the idling and driving was much better.

The stumbling upon acceleration though could of been related to the new TPS, cant imagine why it would do it though after driving 20-25 miles.

Its only done it in that span of 1 trip, I wont know if that was the problem until I travel the distance again. I had a good warm/hot engine though during the process of driving and idling though.

But during the 5-10 mile test drive I did before and after changing of the sensor, it never did do the stumbling upon accelerating from stop.

Add your comment to this topic!