2002 Heater issue, did the burping, but keeps coming back


shynepo3
11-14-2011, 08:47 PM
So I have a 2002 Nissan Altima. I have the same heater issue everyone has, with the sloshing of the coolant behind the dash, as well as no heat when idle. I even get VERY little heat when applying gas. I tried doing the burp procedure - i'm not anywhere near a mechanic, so it was very difficult for me, but the heat did come back - ONLY for a day (few hours). I tried changing the rad cap, got a coolant flush at Nissan, but same problem. The heat worked for a few hours after the coolant flush, but it came back.

So what could it be? My thinking is that the is an air pocket issue, because i DO get heat after doing the burp/flush collant procedure. But something is causing it to have air pockets all over afterwards. Could it be bad hoses to the rad? Or even the whole radiator needs replacing?

The Nissan dealership, I showed them the TSB where it had the burp procedure, and the service guy was like "that's just a coolant flush". So he tells me that if it doesnt fix it, I'm out the 120 they charge for a coolant change. He says for them to diagnose, it's going to cost me (unless i pay for the repair they recommend).

Winter is right around the corner, and I'm getting desperate. Does anyone have any suggestions? I have another mechanic who's fair priced, but he pretty much will do what i tell him to do - meaning he doesnt have the time to keep trying diff things, etc.

Thanks so much for anyone's help....

Add your comment to this topic!