97 Ram 1500 5.9 4x4 No Spark


140
10-09-2011, 04:59 PM
Hi all, first post here. I've searched a few forums and cannot find specific answer to my questions, so I decided to post and see what turns up. Thanks for the all the help so far... here goes.

My 97 Ram 1500 5.9 4x4, started idling rough for appx, 10-15 seconds on cold starts about a week ago. I have had this condition before and the fix last time was to clean the IAC valve pintle and throttle body bore that it goes into. So the first chance I got this weekend I decided to clean it again. I've heard that is a common problem on trucks like mine. Used carb and choke cleaner and a rag just like last time. Put it back together, tried starting the truck... and it hiccuped a couple times then just went to cranking. After poking around a bit I removed a spark plug (happened to be the one on my weak #3 cylinder) and looked it over. Bosch platinum, color seemed normal (about 20k on this set), but the little wire seemed too short and there was gasoline all over the tip of the plug. Checked a couple other plugs and the small wires were definitely not worn as much on those, all had fuel on them. Decided it was time to replace the cap, rotor, wires and plugs anyway, plus just in case I damaged the IAC valve, I replaced that too. None of which has helped. It still cranks and gets fuel, but has no spark. Here is what I've checked. ASD relay has 12V coming from the ignition and through the fuse. With relay in place, ignition on or off checking at coil feed (DG/O) there is only a few millivolts. Remove relay and jumper the terminals, I get 12V at the coil feed. Still will not spark when jumped though. Coil tests 11.31 ohms from secondary to primary, and 1.31 ohms across both primaries which according to alldatapro, is good. Crank position sensor measures infinite ohms across terminals 1 and 2 (per chiltons is also good), but that doesn't rule it out. It is my understanding that if the PCM doesn't receive a signal from crank pos. sensor at all, then there will be no feed to the coil, BUT the fuel pump module wont get anything either. In my case the fuel pump DOES whir when ignition is clicked to run position (for a second or two), and obviously with wet plugs after cranking, the fuel is making it into the cylinder. I replaced the crank position sensor about two years ago. I have no way to test the cam position sensor as I do not have an analog meter or DRB. I have checked the PCM black terminal 7 to the B/GY coil wire and get .2 ohms. All data says anything less than 5 ohms I should checked that wire being thrown to ground... and I've traced it as best I can but cannot find anywhere it could be grounding out.. or even open. I don't believe that the ignition switch could be faulty, but haven't checked that. I shudder at the thought of taking the cap and rotor off yet again (5th time or so) as it is a PITA!! I've checked my firing order and wire placement several times. Either way, there's no spark coming out of the coil. What else would cause no or low voltage to the coil input? Bad PCM... how to check? Bad PCM ground... how to check? Could it still be the crank or cam sensors? I'm stumped. Thanks.

140
10-10-2011, 03:54 PM
Ok so my diag and research has led me down a few different paths. There was a possiblity that either the crank position sensor or cam position sensor could be causing my problems so I went ahead and replaced both. The ASD relay is quickly engaging and disengaging when I turn the ignition to the run position. I tried bypassing the relay with jumpers and can get voltage to the coil, but still cannot get fire out of it. I was thinking this could be do to one of the sensors not working but that apparently is not the case. I've tested the coil multiple times and cant see why it would be the culprit, but I may just go ahead and replace it too. I hate to just throw parts at the problem as it is wasteful, but with out codes to go off of (there are no codes), or a scan tool that can communicate with various sensors, I don't have a whole lot of alternatives. I have also read about a power splice near the ASD relay, but cannot find any splices that are related to this problem, all splices are under the fuse box lid in the engine compartment, and all splices have to do with unrelated fuses. I can't figure where to check the PCM ground at but would like to explore that option as I've read it can cause problems too. Are there any other things that will cause the ASD relay to disengage (open contact)? Is there a chance the coil is bad even though it tests good? The IAC valve kicked this whole thing off and I've looked over the wiring to it, there is no shorts or corrosion. Not to mention that an engine should still run with the IAC disconnected. Any ideas?

140
10-10-2011, 06:57 PM
Just thought I'd give an update and final post as this one is solved. Indeed it was the ignition coil. As a last "what if" attempt, I went ahead a replaced the ignition coil even though it tested good on an ohm meter. I have seen coils test good before and still not produce spark, so I decided to give it a go. The truck fired right up and cleared out all the gas in the cylinders from all the cranking. I'll have to change the oil in case any fuel got down in the crankcase, but I test drove it and checked for codes (97s have a built in DTC checker via switching the ignition on and off a few times). One code came up and that was a 1 2, which is the same as P1195 or slow O2 sensor. I doubt it has to do with a massive amount of pollution coming out of the exhaust at start up, as the PCM doesn't begin normal O2 sensor readings until the engine is up to normal operating temperature. Just in case I'll clear the code and check it again in a few days. If the same code pops again... I guess I'll be wrenching some more!! Thanks for the help.

Chris Stewart
10-19-2011, 04:42 PM
Thanks for the update!

Add your comment to this topic!