Carbon decal big problem...


Supersnake
09-19-2011, 06:09 AM
Hello, first sorry for my bad english...

Ok, here's the problem - I've bought carbon decal (Crazy Modeler) a couple years ago, and now I decided to use it on my Silvia S15...when I unpacked it, the decal had strange marks all over itself - under protective foil were air bubbles, and when I took foil off decal, the "bubble" marks were on decal...I don't know, how to clean it - if it's possible...Or should clear coat solve whole thing?? Here are some pics how it looks:

http://www.shrani.si/f/3l/ZS/4M1OFy5u/dsc03137-large.jpg

http://www.shrani.si/f/1s/ff/1fnUHMMV/dsc03138-large.jpg

http://www.shrani.si/f/Y/5C/1om5bzLe/dsc03139-large.jpg

Please help...

tnx

sjelic
09-19-2011, 06:36 AM
Don't mind those, once you put them on they will disapear.

360spider
09-19-2011, 10:04 AM
These are result of "protective" clear film sticking to decals in storage. They should disappear once you apply the decals.

Supersnake
09-19-2011, 12:14 PM
Hi, I applied decal on hood, and there are still visible "bubble marks", but just silhouette - where bubbles were. I'll upload picture of hood later...Thank you both for help:thumbsup:

cjsbosox
09-19-2011, 01:17 PM
It looks like it got wet. I would not have used it. Sorry this happed to you

360spider
09-19-2011, 01:41 PM
They should go away completely if you apply clear.

Supersnake
09-19-2011, 02:55 PM
They should go away completely if you apply clear.

I'll try with clear...then we'll see.

Tnx guys

Add your comment to this topic!