Our Community is 705,000 Strong. Join Us.


2001 RAM 5.2 P0420 error code


sharkmonkey
08-05-2011, 06:29 AM
Autozone ran the codes on my CEL and found P0420. They gave me four possibilities of what it could mean but I would like to narrow it down a little more if I can.

1. Catalyst efficiency low-bank 1, possible cause, defective Catalytic converter
2. Engine misfire or running condition
3. Large vacuum leak
4. Engine oil leakage into exhaust valve guide

These are four very different issues for this one code. How would I be able to narrow it down to the real cause?
Thanks, -mark

danielsatur
08-05-2011, 12:03 PM
Profile the <make> <model> <year> , and mileage.
How doe's she run?
How's the mpg?

The down stream H02 sensor told the ecu, that the catalytic converter isn't doing its job on bank1.

A Test canbe done on your catalytic converter at any local muffler shop.
For DIY, do a Google ''Youtube auto catalytic converter test''

inafogg
08-05-2011, 12:51 PM
its also could be a bad/lazy 02 sensor

Chris Stewart
08-06-2011, 11:07 PM
P0420 1/1 Catalytic Converter Efficiency Catalyst.
1/1 efficiency below required level.

tempfixit
08-07-2011, 09:23 AM
I agree it could be the upstream 02 sensor, had the same code on my 98 windstar watched the operation of 02 sensor and found it to be lazy, replaced with new sensor and have not had code since. (Put on 5,000 miles since and the vehicle has 200k on it)

good luck

sharkmonkey
08-08-2011, 10:29 AM
Profile the <make> <model> <year> , and mileage.
How doe's she run?
How's the mpg?

The down stream H02 sensor told the ecu, that the catalytic converter isn't doing its job on bank1.

A Test canbe done on your catalytic converter at any local muffler shop.
For DIY, do a Google ''Youtube auto catalytic converter test''

She runs really good as far as I can tell. I've only owned it for about a month. There's no missing or hesitation. I think the MPG is around 15 combined.

So is it most likely the upstream or the downstream sensor?

sharkmonkey
08-10-2011, 06:32 PM
Hmmm, the CEL is no longer lit.

angus10
08-16-2011, 03:53 PM
Get an OEM sensor, not some junk from advance auto or the like. A Bosch is the worst choice.

Add your comment to this topic!