o/d light flashing stops with door locks


johnnyw10
05-17-2011, 08:00 PM
99 windstar when you crank it up and dash lights clearo/d light starts flashing put it in drive and go when auto door locks activate the o/d light goes off trans shifts fine when you put in back in park o/d light starts flashing again and goes back off with door locks?

olopezm
05-17-2011, 09:46 PM
Hello and welcome to the forum!

Is the fluid level OK? Sounds like you might be having some problems with the Transmission Range Switch. It sits on top of the transmission you can see it when looking down behind the air filter assembly. You can look up for TSR in the forum, it's a common problem with windstars.

Oscar.

johnnyw10
05-17-2011, 10:18 PM
Hello and welcome to the forum!

Is the fluid level OK? Sounds like you might be having some problems with the Transmission Range Switch. It sits on top of the transmission you can see it when looking down behind the air filter assembly. You can look up for TSR in the forum, it's a common problem with windstars.

Oscar.
would the trs switch have anything to do with shifter being hard to shift from park to drive and back to park? and thanks for the reply

olopezm
05-17-2011, 10:27 PM
You're welcome :).

Maybe... When I replaced the trs last week on mine the lever became softer than before. Also with the old one, the gear indicator in the instrument cluster wouldn't travel all the way to '1', now it's back to normal...

Another possibility for the hard lever is a set (2) of torx screws under the dashboard, these become loose and the lever feels harder to shift, that would also cause it to wobble depending on how loose they are.

Oscar.

Add your comment to this topic!