fuel electrical or brain problem


bret112
05-08-2011, 08:21 PM
Heres a short version of the troubleshooting i have done and problems

fuel pumps dont run inertia switch is ok I put a hose in 1 gallon can and got siphon to high pressure fuel pump then hooked external battery to fuel pump. pump ran and got pressure in system. turned over engine and still wouldnt start. but when spraying starting fluid in for a few seconds it tried to start but acted like no fuel coming out injectors still only fired on starting fluid.
since when I turn key over the fuel pumps dont run and starting fluid gets it to fire would the problem be the brain and would the brain not let the fuel pumps and the injectors not operate.
I just bought this so I dont know the whole story of what happened to begin with and am working blind.
Also I tested both fuel pumps and replaced the low pressure pump already hi pressure worked fine.
any Ideas will help
thanks

FishFind
05-08-2011, 09:27 PM
Need the year and what car this is. Any light on dash>??? any security light>?

bret112
05-08-2011, 09:41 PM
sorry 1988 ford bronco II 2.9 ltr no lights

lilwhitelude
05-18-2011, 01:22 PM
check to see if the fuel pump relay is sending power to the pump. If so. make sure power is getting down there. Make sure the plugs are firing. If so, use a noid light set and check to see if the injectors are getting voltage. If not, check grounds and power to pcm. Check the pcm fuses to make sure they are in good order. If so. have someone put a scanner on it and see if the pcm is communicating with it, if it is not, you might have a bad pcm, but check every other option before even thinking of replaceing the pcm

ShawnMcIntyre
06-24-2015, 04:54 PM
Hi there I have an 87 Bronco II and it has been running great then I let my wife drive it. She was going along and it started losing power so she pulled over and shut it off. I went to her I started it but could not get RPMs to go up then it started running real rough and now it will turn over but not start. Can somebody give me and idea of where to start? I have owned this Bronco II for 24 years it is on it's second engine. My wife jokes I would get rid of her before it.

jamo1234
01-11-2016, 10:14 PM
Found bared wires in harness running across top of power steering pump.

Add your comment to this topic!