99 windstar issues HELP


daprinna1
05-04-2011, 11:01 PM
I drove over a bump the other day and lost all control functions on dashboard, turn signal, hazard, fuel gauge, speedometer, oddemeter, temp lvl, but i did still have tail lights, head lights, blower (fan) and radio. The radio and lights stayed on even after the van was shut off. Also the only way to get the lights and radio to turn off without disconnection the battery i have to unplug the fem (front electronic module)?

Windstartled
05-04-2011, 11:53 PM
I'm assuming you have checked if battery connectors aren't loose? On my 2000 Winnie the connector to the negative pole had once become loose (but not disconnected outright) and this had caused the van to experience all sorts of weird electrical phenomenon: headlights stayed on even when switched off, or they would turn off but then taillights would come on instead, gauges "bounced", symphony of clicks would erupt from behind the dash, etc. and the engine would not start. Took me several hours to figure this one out.

daprinna1
05-05-2011, 05:18 AM
Yes the battery connectors are fine. I also can not get my van to start now. I tried to start it when i got home it started fine the next day it would not start at all and still will not. Thought it may be computer related but spent 128.99 at autozone and had it flashed at factory still does the same thing. :crying:

Windstartled
05-05-2011, 07:26 AM
This happened after you drove over a bump, I would suspect either something shorted or disconnected. Does the starter make any noise when you turn the key?

daprinna1
05-05-2011, 03:32 PM
no nothing its like the starter went out but we can get it to try and kick over by the seloniode.

wiswind
05-05-2011, 08:00 PM
Verify the electrical connections at the starter.....including the ground connection.
This is a high corrosion area.
Is the battery maybe also going bad?

Check the connections on the back side of the power distribution box in the engine compartment, as well as reseating the relays and fuses inside it.
Try the same in the fuse panel under the dashboard......driver's side......as well as verifying that the plugs are secure.

daprinna1
05-06-2011, 09:54 AM
I can get the van to try and turn over when i bypass the starter and just jump the selonoid. all fuses and relays are good when i checked them the other day

daprinna1
05-06-2011, 09:55 AM
also it is brand new battery good charge even though didnt need new one got one anyway

daprinna1
05-08-2011, 08:57 PM
so turns out that fuse number 16 was not quite blown but was causeing the issue now that fuse keeps blowing what could cause this?

Add your comment to this topic!