1996 Eclipse RS 2.0 Non turbo Fuel pump reset


donidavis
04-29-2011, 01:31 PM
Does anybody know if these cars have a fuel pump reset switch? My car was parked and it got hit pretty hard by a truck and now the fuel pump isnt pumping! There is no pressure in the fuel rail... The only reason i ask is because someone told me that when these cars get hit it shuts off the fuel pump and i looked in the haynes and chilton book but i didnt see anything about it! Can someone help me?

Blackcrow64
04-29-2011, 05:34 PM
I have not heard of this for these cars before... Maybe one of the non-turbo guys will be able to chime in and say for sure one way or another though.

When you turn the key forward to the first click, you can't hear the pump prime at all at this point? Usually it's easier to hear with the back seat out and the cover off the top there... Have you checked to verify that nothing was damaged with wiring to the pump? (I'm assuming if it was hit in the side of the car.)

donidavis
04-29-2011, 11:57 PM
Yes i checked to see if the pump was priming but i didnt hear it... thats why i thought the fuel pump was messed up! then i heard about the reset switch.... i mean bro ive never heard about it either but, its not a bad idea if it had one!

Blackcrow64
04-30-2011, 05:15 PM
I know newer cars have fuel pump kill switches but I don't think they did back in the day of these cars... Did you try a test light back there to make sure power is at least making it that far? Check the fuse for the fuel pump?

donidavis
05-01-2011, 12:12 AM
Na i think ima check that in the morning and i will let you know whats going on back there! thanks dude!

donidavis
05-01-2011, 12:15 AM
Also is there a fuse for the pump other than a relay?

Blackcrow64
05-01-2011, 11:38 AM
Yeah I believe that fuse is under the hood with other major fuses.

donidavis
05-02-2011, 11:16 AM
Ok I got the test light and i put a 12v battery back there so i know i will have a good ground and i didnt find any power back there to any of the terminals. I had the key switch on also still no power! I also looked for a fuel pump fues and i couldnt find one. I even changed the fuel pump relay. But that lil connector by thr radio could that be the problem?

Blackcrow64
05-02-2011, 03:27 PM
What little connector by the radio?

Blackcrow64
05-02-2011, 03:30 PM
From what I've read online the relay next to the ECU usually goes bad. It can be accessed by taking off the passenger side panel of the center console and it should be right there. Is that the one you already replaced?

david-b
05-03-2011, 09:01 AM
The 420a does not have a fuel pump reset. Sounds like either the relay got tripped or fuse, but I can't remember if it has a fuse for the fuel pump.

There is nothing relating to the fuel pump by the radio on the 420a. The ECU is in the engine bay, not in the center console like the 4g63. The only relay in the dash by the radio is the turn signal unit.

Check the relays along the firewall, right behind the battery. Make sure those are working first. Should have either 2 or 3, depending on if it's manual or auto.

donidavis
05-04-2011, 01:46 AM
Ok i figured that out it was the fuel pump! i replaced it... now its still not starting but we opened the throttle body and squirted starting fluid in it and it started but now idk what it is! im going to try the crankshaft sensor plug it is 9 diff ways to connect it. I know the yellow one from the harness is the power wire... but is there anyother things that could cause it not to start. I checked the wires, plugs, coil pack got gas new fuel pump and filter so IDk? what do yall think?

Add your comment to this topic!