AC is not cold and is blowing cool air from one side


starqueen07
04-25-2011, 08:05 PM
I have a 2003 Ford Explorer and my ac is not blowing cold air. on the passangers side its blowing semi cool air and on the drivers side its blowing hot air. if i turn up the speed of the fan it does get a little bit cooler. the back does not seem to cool either. i do have the dual control but i dont have it turned on and it doesnt work. what can i do to fix this?

thanks

brcidd
04-25-2011, 08:30 PM
Number one failure mode of mobile a/c systems is loss of charge. My data says 65% of cars out there lose refrigerant... so knowing this and the fact the one of the symptoms of low charge is cooling on only one side of evaporator (which equates to one side of cabin- most always passenger side). If you add a can, you will soon learn that this is the case.

But as always, you should find and fix the leak- then evac and recharge to system spec. and all will be fine.

starqueen07
04-25-2011, 09:05 PM
thanks ill try that. i ran a self diagnostic on the ac and it showed me some codes: 2267 and 2266 would you know what those mean?

shorod
04-25-2011, 10:27 PM
The code 2266 is for a Left Side Blend Door circuit failure and the 2267 is for a Right Side Blend Door circuit failure.

-Rod

brcidd
04-25-2011, 10:36 PM
Since you have codes set- you need to seriously consider that you have blend door failures- check out this link- see if it applies to your situation.

heatertreater (http://heatertreater.net/Ford%20Explorer%2002-08.html)

Add your comment to this topic!