1999 Chevy s-10 Please help


dynastykid22
04-05-2011, 10:34 AM
Truck cuts out when I give it gas, almost feels it is getting an extreme amount of air, bad hesitation, idols perfectly fine, starts fine. I have changed all spark plugs, wires, fuel filter, air filter, oil filter, and changed the oil. Fuel pump sounds fine, there is no distributor cap, only coil packs, also no check engine lights.

Any advice on the next step would be appreciated.

Thank you

JT

Scrapper
04-05-2011, 10:54 AM
Truck cuts out when I give it gas, almost feels it is getting an extreme amount of air, bad hesitation, idols perfectly fine, starts fine. I have changed all spark plugs, wires, fuel filter, air filter, oil filter, and changed the oil. Fuel pump sounds fine, there is no distributor cap, only coil packs, also no check engine lights.

Any advice on the next step would be appreciated.

Thank you

JT what moter you got in there 4cyl or v/6 and is it multiport fuel injection? could be tps or cps sensor also you could try cleaning maf sensor or gunked up throtle body take hose off throttle body and look in at the butterfly and see if it's dirty if it is they got spray to clean it.

dynastykid22
04-05-2011, 11:00 AM
It is a 4cyl 2.2, manual.

dynastykid22
04-05-2011, 11:03 AM
Will try em all and let you know.

Thank you

JT

MT-2500
04-05-2011, 01:02 PM
Will try em all and let you know.

Thank you

JT

Before throwing parts at it do some proper testing.

Any check engine light?
Check fuel presure for up to specs.
Check for good hot blue spark to all plugs.

Let us know what you find there.

Add your comment to this topic!