truck hardly idleing


marinetanker18
03-01-2011, 06:23 PM
ok everyone, I have a 83 pickup with the 225/auto, recently installed a new electric fuel pump, new coil, mopar electronic ignition, and a 1920 holly 1bbl carb, drove truck today, was doing great until i got home, sat for a while went to tinker somemore on it and it ran like straight crap, missing, stumbiling, surging and will not hardly run when put into gear, i have checked the timing, idle plug gap, relucter gap, wires, cap, ballast, you know all the normal. I have no idea what the problem is eny thoughts:banghead:

DVSNCYNIKL
03-01-2011, 06:50 PM
ok everyone, I have a 83 pickup with the 225/auto, recently installed a new electric fuel pump, new coil, mopar electronic ignition, and a 1920 holly 1bbl carb, drove truck today, was doing great until i got home, sat for a while went to tinker somemore on it and it ran like straight crap, missing, stumbiling, surging and will not hardly run when put into gear, i have checked the timing, idle plug gap, relucter gap, wires, cap, ballast, you know all the normal. I have no idea what the problem is eny thoughts:banghead:


Missing, stumbling, surging, sound like a fuel delivery problem. Is the new fuel pump delivering enough fuel? Sounds like you're going to need to do some trial and error. I would start there and ensure proper delivery. If the fuel is there, then go through the electrical.

marinetanker18
03-01-2011, 10:10 PM
yes the new fuel pump is giving it plenty of fuel, I will try to check over the ignition system again tomarow its been 1 problem after another with this truck.

DVSNCYNIKL
03-02-2011, 09:34 PM
yes the new fuel pump is giving it plenty of fuel, I will try to check over the ignition system again tomarow its been 1 problem after another with this truck.

Answer me this, before the work you performed on this truck, did the truck have any of the symptoms you are describing? If not, at least it narrows down the possibilities of an underlying problem.:smile:

marinetanker18
03-03-2011, 03:32 PM
Yes, the truck had these problems before, it was origanlly equiped with the lean burn computer control system, after replacing all that is has gotten better but still not like it should.

jpb53
03-03-2011, 05:21 PM
What is your fuel pressure regulated to? Manual pump pressure is 3.5 to 5lbs. Could your electric pump be causing carb to flood?

marinetanker18
03-04-2011, 01:39 PM
i have a regulator installed, set to 4.5 lbs. checked to be right around that with a guage, pulled the valve cover last night to check for enything broken or missing everything looked good, so i have no clue as to what it could be.

Add your comment to this topic!