Our Community is 705,000 Strong. Join Us.


Mystery vacuum line & electrical connector


OldLugNut
02-22-2011, 06:22 PM
I recently bought a 1999 Amigo V6 5spd and noticed a vacuum line that's been plugged with a screw and a mystery electrical connector. They are shown in the attached photos. I'm suspecting the electrical connector might be for the cruise control, which my car does not have. The plugged vacuum line is a mystery to me. Can anyone tell me where they should go?

Mikes99
02-23-2011, 11:00 PM
The vacuum line on mine is plugged with a factory cap on it. The electrical connector is the same as mine. Im guessing they both might be for cruise control.

OldLugNut
02-25-2011, 03:35 PM
Can you tell me if the cap on your vacuum port is a simple one that just plugs it up or does it have a small filter like the larger one in the attached picture? My car has a couple other vacuum switches like this one over by the brake booster and they both have small round black plastic filters capping that same vacuum port. I've ordered a repair manual & once it gets here I hopefully won't be posting as many silly questions like this. Thanks for your help!

Mikes99
02-26-2011, 09:49 AM
the big one
http://inlinethumb58.webshots.com/2937/2847501350037408053S425x425Q85.jpg (http://rides.webshots.com/photo/2847501350037408053UTmhsP)


More shots here: http://thumb13.webshots.net/t/87/87/4/63/4/2852463040037408053HnLxDy_th.jpg (http://rides.webshots.com/album/579410917JMJLHF)

OldLugNut
03-05-2011, 10:02 PM
Thanks Mike99 -- I appreciate your help!

Add your comment to this topic!