Our Community is 705,000 Strong. Join Us.


Backfiring and sputting on 1996 v6 4.3 C1500


chevymaine
02-17-2011, 11:45 PM
:headshakeI have a 1996 V6 4.3 chevy that was fine, I put gas in it and all of a sudden it started backfiring and sputtering, and now it has an rough idle. I have replaced the distributor cap twice, wires, and spark plugs. Number 1 spark plug is the one that is misfiring and the engine light is on. When sitting idle the check engine light will blink. Any help in this matter will help. Thank you sincerly Chevymaine

MT-2500
02-18-2011, 08:19 AM
:headshakeI have a 1996 V6 4.3 chevy that was fine, I put gas in it and all of a sudden it started backfiring and sputtering, and now it has an rough idle. I have replaced the distributor cap twice, wires, and spark plugs. Number 1 spark plug is the one that is misfiring and the engine light is on. When sitting idle the check engine light will blink. Any help in this matter will help. Thank you sincerly Chevymaine

Bliking light is a missfire.
What are your engine running code no?
What kind of plugs did you feed it?

Can you feel the miss?

Are you sure you did not get bad gas?

j cAT
02-18-2011, 08:51 AM
:headshakeI have a 1996 V6 4.3 chevy that was fine, I put gas in it and all of a sudden it started backfiring and sputtering, and now it has an rough idle. I have replaced the distributor cap twice, wires, and spark plugs. Number 1 spark plug is the one that is misfiring and the engine light is on. When sitting idle the check engine light will blink. Any help in this matter will help. Thank you sincerly Chevymaine


when after fueling the engine does this , it is most times water in the fuel. add dry gas to see if it helps.

chevymaine
02-18-2011, 01:32 PM
I didn't mean that the gas was bad, but the distributor went bad and it started sputtering and backfiring. That is when I changed the distributor cap. It runs fine in accelleration, but in idle it is rough. I removed the number 1 spark plug wire, and it runs the same, it does not idle down, like the other 5 do. What do you think the problem could be? Even Autozone told me it was a misfire on number 1, but how do I fix this problem. Thanks

4x4junkie
02-18-2011, 02:02 PM
if you remove the number one wire to find no difference, its quite possibe the number one spark plug wire is defective!

MT-2500
02-18-2011, 02:29 PM
I didn't mean that the gas was bad, but the distributor went bad and it started sputtering and backfiring. That is when I changed the distributor cap. It runs fine in accelleration, but in idle it is rough. I removed the number 1 spark plug wire, and it runs the same, it does not idle down, like the other 5 do. What do you think the problem could be? Even Autozone told me it was a misfire on number 1, but how do I fix this problem. Thanks

IF MISSING OR MISSFIRE.
Check for good spark to that cylinder.
If good spark pull plug and see if wet or dry on the end.
Post back which.
Switch plug with agood firing cylinder.
Post back what tha does.
If still miss on same cylinder.
Run a compression check on all cylinders.
POST BACK RESULTS OF COMPRESSION CHECK.
If good spark and good plug and good compression and no vacumn leaks I would run a good fuel pressure check and for injector pulse to that cylinder.
Post back fuel pressure readings.

What are the code no auto zone got out of it?

j cAT
02-18-2011, 05:56 PM
I didn't mean that the gas was bad, but the distributor went bad and it started sputtering and backfiring. That is when I changed the distributor cap. It runs fine in accelleration, but in idle it is rough. I removed the number 1 spark plug wire, and it runs the same, it does not idle down, like the other 5 do. What do you think the problem could be? Even Autozone told me it was a misfire on number 1, but how do I fix this problem. Thanks


when ever you mess with the plug wires you must use an OHMMETER to check for proper resistance . when removing wires they break. also to prevent the new wires from failure use di-electric grease in the wire boots. this keeps the water and air out of the connection in the boot..no corrosion can occur.

Add your comment to this topic!