no tail lights or dashlights


Davschmidt
02-17-2011, 04:31 PM
I have a 2003 regal. I have no tail lights or dash lights. The warning chime (that chimes when you leave your lights on or key in) chimes all the time, even with the key removed. The auto headlight function does not work. I replaced the headlight switch with no change.
When the lights originally went out, I found a burnt fuse (for tail lights) in the fuse box on the right side of the dash. I replaced the fuse and the lights worked for about a day. The fuse is still good, but the lights do not work? Is there another fuse some place else?

Any ideas? Thanks

BNaylor
02-18-2011, 08:51 AM
You might have a bad ignition switch assembly or key cylinder.

Also, check for any blown fuses related to the Daytime Running Lights. If the DRL fuse is bad you will not have auto headlights.



100% free webcam site! (http://showmewebcam.com/?p=0) | Awesome chicks and it is absolutely free! (http://showmewebcam.com/?p=2) | Watch free live sex cam - easy as 1-2-3 (http://showmewebcam.com/?p=4)

Davschmidt
02-18-2011, 10:22 AM
Thanks for the help. I found another thread on AF that identified the problem. It was a couple of badly corroded tail light sockets that were blowing the fuses under the hood (LPark) and in the right side of the dashboard. It appears that the Regal has a problem with water intruding in the tail light section. I cleaned the sockets and caulked the seams on the tail light section. So far, so good.

Thanks again. This forum has been a real help to me over the years.

Add your comment to this topic!