4l60 overdrive problems


razorbaq
02-11-2011, 09:10 PM
I have a 93 s10 4.3 which I believe has a 4l60 tranny. Well I am having a problem starting out in overdrive, But if i put the truck in normal drive it seems to be fine then when im at high rpms in 3rd I can shift into overdrive fine. But If I start in overdrive It seems to slip then not shift just high rev and if it does shift It slams hard into gear. This all started when I put alot of weight in my bed because of all the snow weve been having, And stupid me not thinking I drove around in overdrive the whole time for about a week. My truck is putting off a trouble code 82 which is for shift solenoid 3-4. But the code does not always come on when the problem is happening, Also sometimes I get in truck after its been sitting for a while and It shifts and drives fine.

j cAT
02-12-2011, 09:51 AM
replace the fluid and filter. use the new dexron VI. DO NOT USE ANY DEXRON III....

how much load did you put in ?

my fleet of vehicles has a 94 s10 4X4 5sp. 4.3L. the bed we have now 4bags of sand /heavy plastic container. about 150lbs. with some AT tires excellant traction. we have now 70 plus inches on the ground..

send some warm weather our way.

razorbaq
02-12-2011, 11:48 AM
I had two 50 gallon drums of water in there so about 700 pounds but Most of the time it was only 1 drum about 400 pounds

j cAT
02-12-2011, 12:14 PM
I had two 50 gallon drums of water in there so about 700 pounds but Most of the time it was only 1 drum about 400 pounds

water is 8lbs/gallon 100gal. is 800lbs..I would not carry that load on my S10. that is quite heavy.

the fluid when towing gets very hot in OD. cross fingers and do the fluid change. If you still have the dexron III in there , its shot.

razorbaq
02-12-2011, 02:30 PM
Ok I have a problem with the rear end not the tranny, I jacked the rear up and took the cover off the pumpkin and the spider gears and pinion gears all look fine, But when I turn the tires by hand the spider gears turn but the pinion doesnt then it sort of does then just sits still, If I turn the drive shaft by hand the pinion then turns and the left tire spins but the right tire doesnt. Everything looks good(the gears) I just dont understand You can hear the rear end humming when you drive and make a light clicking noise

j cAT
02-12-2011, 04:49 PM
Ok I have a problem with the rear end not the tranny, I jacked the rear up and took the cover off the pumpkin and the spider gears and pinion gears all look fine, But when I turn the tires by hand the spider gears turn but the pinion doesnt then it sort of does then just sits still, If I turn the drive shaft by hand the pinion then turns and the left tire spins but the right tire doesnt. Everything looks good(the gears) I just dont understand You can hear the rear end humming when you drive and make a light clicking noise

go thru the axle removal proceedure , check for broken hardware.

razorbaq
02-12-2011, 05:00 PM
Ok I noticed the pinion flange was seperated from the housing, After I took it off there was a smashed up bearing ball in there, Just one. Looks like there should be bearings in there, Autozone knew nothing about it and Napa sold me a rear pinion flange seal, They say it takes no bearings, It sure looks like there should be bearings in there, And if not where did the one bearing ball come from, Theres no way for it to get in there from somewhere else.

j cAT
02-12-2011, 05:15 PM
Ok I noticed the pinion flange was seperated from the housing, After I took it off there was a smashed up bearing ball in there, Just one. Looks like there should be bearings in there, Autozone knew nothing about it and Napa sold me a rear pinion flange seal, They say it takes no bearings, It sure looks like there should be bearings in there, And if not where did the one bearing ball come from, Theres no way for it to get in there from somewhere else.

you have 3 bearings. 2 wheel axle bearings left right. then the drive shaft pinion bearing. this is the bearing that broke. now the gears do not engage properly. this will need to be repaired by shimming this to engage correctly when the new pinion bearing is installed.

this is beyond my level of knowledge. never did it !

razorbaq
02-12-2011, 05:52 PM
I cannot find nothing about this bearing I need, Looked all over the net (pinion flange bearings) and nothing. Im about to just put it back together without the bearings seeing how no one at the auto parts store thinks it takes bearings. I dont even know what shimming Needs to be done, what to use as shimms Im totally lost.

j cAT
02-12-2011, 08:46 PM
I cannot find nothing about this bearing I need, Looked all over the net (pinion flange bearings) and nothing. Im about to just put it back together without the bearings seeing how no one at the auto parts store thinks it takes bearings. I dont even know what shimming Needs to be done, what to use as shimms Im totally lost.

like I said I am no expert on this type of work. leave this up to the guys that do this all the time. go here to see what your in for :http://www.s10forum.com/forum/f13/help-how-to-change-front-outer-pinion-bearing-423058/

parts "like" this is what would be required :http://www.autopartswarehouse.com/sku/Chevrolet/S10/Timken/Differential_Bearing/1993/Base/6_Cyl_4-dot-3L/TMDRK320.html?loc=Rear&tlc=Brakes%2C+Suspension+%26+Steering&intcmpid=

Add your comment to this topic!