Dome Light not working

01-22-2011, 09:24 PM
Hello Everyone,

My dome light does not work anymore(Ford Escort). I tried a new bulb and the light still doesn't not work. Will changing the fuse or installing LED lights solve the problem? I looked at my manual and I couldn't find the dome light fuse. The closest thing I found was sunroof fuse. The on/off switch and the bulb are together in the dome light assembly. I've seen videos were the on/off switch and bulb are separate. Two dealerships have already told me that the dome light assembly for my car is obsolete. The junkyard should have it. But I'm not sure if they will give me a refund if the part doesn't work.

01-22-2011, 09:47 PM
The drivers door has the most wear + tear, look for the Adjar door switch.

01-23-2011, 08:54 AM
What year is it? Is there anything else that quit working? Radio, instrument lights?

01-23-2011, 04:44 PM
I want to thank everyone who respond back to me. The year of the car is 2001. I forgot to mention one thing. I'm not sure if it will help. I put some crazy glue on the on/off swicth a while back ago. The dome light worked for a few days. Then it stopped working and hasnt worked since then.

01-23-2011, 04:55 PM
AzTumbleweed- Nothing else stopped working. This problem started after I got a new battery replaced. Can this be related?

01-24-2011, 09:01 AM
The battery replacement shouldn't have anything to do with it. When a fuse blows there is usually more than one thing that quits working because they share a fuse. The crazy glue would have long since been dried so I wouldn't think that would be the problem. If you removed the lamp when you glued it then make sure the screws are tight. Loose screws would cause a bad ground connection.

01-24-2011, 08:50 PM
Thanks for your help.

Add your comment to this topic!