Our Community is 705,000 Strong. Join Us.


1994 dodge 1/2 ton pickup 318 eng


rwgclg
01-20-2011, 08:17 PM
I have a 1994 dodge 1/2 ton pickup with 318 eng. with 270,000 miles. I recently replaced the fuel pump and the truck has been running ok. My problem is when the truck gets warm the idle starts cyling up and down (rpm) the rpm drops down so low that the eng. dies, it restarts fine and as long as you keep the rpm up the eng. runs ok. I've noticed that the cabin temp takes a long time to get warm and the fan only works on defrost mode. I've turned the key off and on three times to get the codes, they are 12, 37, 55 andy advise would be helpfull

MagicRat
01-20-2011, 08:56 PM
Check out this site for your codes
http://check-engine-light-codes.blogspot.com/2006/04/chrysler-1985-95-obd1-code-self.html

But I do not think your codes are related to your problem.

You may have an intake manifold vacuum leak. The defroster problem means no vacuum is getting to the ventilation controls. When this happens, the system defaults to defrost mode for safety reasons.

Get under the hood and look for a loose, or missing vacuum line. Sometimes, you can hear such a loose line "whislte" when the engine is idling. If or when you fix the vacuum leak, the drivability problem may be fixed as well as the ventilation controls

82Stang
01-22-2011, 06:23 PM
Yes, that up and down idle sounds like a vacuum related issue. Or an issue with one of the sensors related to vacuum like the IAC or the TPS or the EGR, anything around the upper intake that connects to a port. Even if things 'look' okay, try unhooking and rehooking vacuum lines/hoses to make sure they are actually using vacuum and holding.

Add your comment to this topic!